Dumb AP with internet access in web interface

Hi. Is their someone here knows how to make the internet work inside the web interface with "dumb AP" mode?. Or it is not possible for OpenWRT to make this one?

I deleted the WAN interface and leave the LAN interface. The purpose of having internet inside the web interface is to use the "Attended Systemupgrade".

You either configure dhcp-client or make sure that gateway and DNS settings are correct (and set) for your static configuration.

1 Like

Will you show me the way on how to set that said settings?

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

There is no need to redact I use an open network because I have a captive portal in my network.
Here are the settings that you have asked for.

root@Xiaomi-4A:~# ubus call system board
{
        "kernel": "5.15.134",
        "hostname": "Xiaomi-4A",
        "system": "MediaTek MT7628AN ver:1 eco:2",
        "model": "Xiaomi Mi Router 4A (100M Edition)",
        "board_name": "xiaomi,mi-router-4a-100m",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.0",
                "revision": "r23497-6637af95aa",
                "target": "ramips/mt76x8",
                "description": "OpenWrt 23.05.0 r23497-6637af95aa"
        }
}
root@Xiaomi-4A:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        option ipv6 '0'
        option bridge_empty '1'
        list ports 'eth0.1'
        list ports 'eth0.2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option delegate '0'
        option ipv6 '0'
        option gateway '10.0.0.1'
        list dns '10.0.0.1'
        list ipaddr '10.0.31.4/19'

config device
        option name 'eth0.2'
        option ipv6 '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '6t 4 2'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t 0'

config device
        option name 'eth0'
        option ipv6 '0'

config device
        option name 'eth0.1'
        option type '8021q'
        option ifname 'eth0'
        option vid '1'
        option ipv6 '0'

config device
        option name '5Ghz'
        option ipv6 '0'
root@Xiaomi-4A:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option band '2g'
        option htmode 'HT20'
        option country 'US'
        option cell_density '0'
        option channel '6'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option cell_density '0'
        option htmode 'VHT80'
        option country 'US'
        option channel '36'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'ap'
        option ssid 'BERIN PISOWIFI'
        option encryption 'none'
        option isolate '1'
        option ifname '5Ghz'
        option network 'lan'
        option short_preamble '0'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'BERIN PISOWIFI'
        option encryption 'none'
        option isolate '1'
        option ifname '2.4Ghz'
        option network 'lan'
root@Xiaomi-4A:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'
        option dynamicdhcp '0'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
root@Xiaomi-4A:~# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option synflood_protect '1'
        option forward 'ACCEPT'

Wow, big network there 10.0.31.4/19, is this for home use?
Are you able to ping your dns/gw?
Btw i would avoid using 10.0.0.1, default ip of many switches/routers.

I use this IP because I sell Wi-Fi access here at my place we call it WIFI VENDO and yes I'm able to ping. and using collectd

If you can also ping a public ip then you are good to go.
If not, you might missing a default route 0.0.0.0/0 using 10.0.0.1.

I have tried to use the opkg update but no luck there's no internet. while on my default firmware routers like TP-Link C64 Access point mode. It can have internet inside the web interface. Can internet access run without the WAN interface in OpenWRT?

Do I have to change something? because all of my dumb ap are set to that kind of settings.

Yes you can have internet, wan is not mandatory.
However, having a valid route, gw and dns it is!
Try and ping 8.8.8.8 or 1.1.1.1.
What is the output of "ip route" ?

1 Like

Add this at the end of your network config and reload

config route 'internet'
        option interface 'lan'
        option target '0.0.0.0/0'
        option gateway '10.0.0.1'
1 Like

thanks man it works

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.