"Dumb AP" with 2 SSIDs (untagged/tagged)

Hello,

I'm new to OpenWRT and recently followed instructions to compile an early build for my Netgear WAX206.
Everything seems to work as it should. I believe this setup uses "DSA".

I would like to use the WAX206 as an AP for two isolated VLAN networks on one trunk cable.

Unfortunately I'm not yet smart enough to achieve the configuration I need to make it a drop-in replacement for the old APs.

What I'd need is just 1 Ethernet Port:

-> lan1 untagged + SSID1 + AP webinterface
-> lan1 tagged VLAN1003 + SSID2

no DHCP/DNS/other functionality.
So essentially a "dumb AP" with two SSIDs pointing to two networks; one untagged on lan1, one tagged 1003 on lan1.

here is the default configuration output:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '[redacted]'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

wireless:
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'HE80'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

If I remove the existing lan1 port from br-lan, create a 'static' interface with the correct subnet configured and link an SSID to this network, I can't seem to get an IP or access the webinterface with a non-conflicting static IP on both sides (openwrt interface and the client machine), even though the ethernet port is connected.

I've spent about six hours tonight trying to get this to work. Do I perhaps have to create a bridge for each device? Should I always include eth0? Thanks for any pointers.

Try adding this to your config:

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '1003'
	list ports 'lan1:t'

config interface 'dumaponly'
	option device 'br-lan.1003'
	option proto 'none'

and change the exiting lan's device to br-lan.1

Other things you need to do:

  • set your lan to have an IP address is in the same subnet as, but does not conflict with your main network (not being used by any other devices and outside the DHCP pool)
  • set the DHCP server to ignore the lan interface so that it doesn't try to issue DHCP leases. Also turn off DHCPv6 related items.
  • create a new SSID on and link it with the network dumaponly (feel free to rename that, btw -- just a placeholder).
1 Like

Thank you, thank you, thank you.
This did exactly what I wanted to achieve.
I initially used the luci webinterface in attempt to achieve this configuration, but the text based configs seem much more elegant. When I have the time I'll look more into learning the syntax, but for now this is perfect.
Thank you again and happy new year!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.