Dumb AP system time

I've setup a router to be a dumb AP. I have only lan interface with a static address.
The problem is that the device doesn't update system time, because it can't resolve domain names.

How can I fix it?

Add a NS resolver in the LAN interface.

uci set network.lan.dns='X.X.X.X'
uci commit network
service network restart

I tried this a different way, maybe something wrong. It works.

You can apply it in Luci web interface, or edit the config file directly.
Plenty of ways to configure OpenWrt.

I tried to edit config. That is what I always do, but something went wrong.

option dns ''

was enough. And enable dnsmasq back. Thx anyway.

You need both gateway and dns set up in order for local access to the Internet (e.g. NTP) to work.

Usually I make the LAN of a dumb AP a DHCP client, which makes this automatically controlled by the main router.

Correct. I have gateway set already.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.