Dumb AP on Netgear WNDR4300v1

Some time ago I got help creating a VLAN on DL-WRX.

I want to add another router (Netgear WNDR4300v1) to this network and set it up as a dumb access point. However I've been having trouble setting up it up. I've tried many different configurations for the VLAN but in each case the router becomes unreachable. I'd be immensely grateful for any guidance in setting this up.

can you kindly post the current configuration (/etc/config/network) of your "Dynalink DL-WRX36" and that of your "Netgear WNDR4300v1"

which ethernet port connects your "Dynalink DL-WRX36" to which ethernet port of your "Netgear WNDR4300v1" ...

Thank you! Here they are:

Dynalink

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd0e:4ba4:f494::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

Netgear

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd0f:8c7c:4b99::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth0.2'
	option macaddr '28:c6:8e:0a:1e:74'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

config interface 'guest'
	option proto 'dhcp'

config interface 'iot'
	option proto 'dhcp'

My network currently has two Dynalink routers, one serving as the router and other serving as a dumb AP. I'd like to connect port 2 of the router to port 2 of the Netgear dumb AP.

if this is the current setup (of the main router) you will have to follow what was told in the post:

since no vlans have been created for traffic ...

ps: I see that your "NETGEAR WNDR4300" has not yet switched to DSA, it will be more complicated since I don't have any routers at hand that are still on "swconfig"

https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=ath79%2Fnand&id=netgear_wndr4300

since I also had problems creating the vlans, try to see if this helps you (but currently all the routers I have have switched to DSA):

Can you clarify....

You have a DL-WRX36 that we previously had configured as the main router and it had the VLANs setup as follows:

  • Port 1: VLAN 1 (lan) untagged
  • Port 2: VLAN 2 (guest) untagged
  • Port 3: VLAN 3 (iot) untagged
  • Port 4: VLAN 1 untagged; VLANs 2 and 3 tagged

Is this router still setup with port 4 as the trunk port per my description above?

You seem to have a Dynalink device that is in the default state based on your earlier config dump. You mention that you have 2 dynalink routers, but the config shown above would conflict with the main router. With that in mind, I want to make sure that this is a separate device that is being configured as a bridged AP and not currently connected to the network... is that correct??

Assuming that is the this default state Dynalink device is being configured as an AP:

  • which port is used as the uplink (presumably to the main router's port 4)?
  • Port 2 will be used as to connect to the WNDR4300v1, correct?
  • what about ports 3-4 what should they do?
  • What address should the Dynalink AP use on the network? (or should it be set to DHCP)

And what about the ports on the WNDR4300v1?

  • Port 2 is the uplink?
  • What about ports 1-3?
  • What address should the WNDR4300v1 AP use on the network? (or should it be set to DHCP)

It's also worth noting that the logical port numbers in the config for the WNDR4300v1 may or may not correspond to the physical port numbers on the back of the unit, so there is a slight chance of a mistake here, but it will be easy to figure out and easy to fix if necessary.

Now I'm not sure which Dynalink config - I thought it was for the main router. I redownloaded the configs from the two Dynalink routers and am posting them here::

Dynalink Main Router

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd0e:4ba4:f494::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan.10'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'guest'
	option device 'br-lan.20'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'

config interface 'iot'
	option device 'br-lan.30'
	option proto 'static'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '20'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'
	list ports 'lan4:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '30'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'
	list ports 'lan4:t'

Dynalink Dumb Access Point

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd0e:4ba4:f494::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan.10'
	option proto 'static'
	option ipaddr '192.168.1.2'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'

config interface 'guest'
	option device 'br-lan.20'
	option proto 'static'
	option ipaddr '192.168.2.2'
	option netmask '255.255.255.0'
	option gateway '192.168.2.1'
	list dns '192.168.2.1'

config interface 'iot'
	option device 'br-lan.30'
	option proto 'static'
	option ipaddr '192.168.3.2'
	option netmask '255.255.255.0'
	option gateway '192.168.3.1'
	list dns '192.168.3.1'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '20'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'
	list ports 'lan4:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '30'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'
	list ports 'lan4:t'
  • Port 2 is the uplink?

I set Port 2 as the uplink just while setting up the access point. I think Port 1 would be better though.

  • What about ports 1-3?

I'd like to allow devices to connect to the LAN via ethernet on ports 2-4

  • What address should the WNDR4300v1 AP use on the network? (or should it be set to DHCP)

192.168.1.3

On the dynalink AP, edit the guest and IoT networks to be unmanaged, like this:

config interface 'guest'
	option device 'br-lan.20'
	option proto 'none'

config interface 'iot'
	option device 'br-lan.30'
	option proto 'none'

On the Netgear, we'll make some new VLANs on the switch... I'm making a guess that logical port 1 is the same as the physical port 1:

config switch_vlan
	option device 'switch0'
	option vlan '20'
	option ports '1t 0t'

config switch_vlan
	option device 'switch0'
	option vlan '30'
	option ports '1t 0t'

Next, create bridges:

config device
	option name 'br-guest'
	option type 'bridge'
	list ports 'eth0.20'

config device
	option name 'br-iot'
	option type 'bridge'
	list ports 'eth0.30'

Now we can add two unmanaged interfaces:

config interface 'guest'
	option device 'br-guest'
	option proto 'none'

config interface 'iot'
	option device 'br-iot'
	option proto 'none'

The last thing to in the network file is to adjust your lan address so you can manage the device properly:

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.3'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option dns '192.168.1.1'

All that is left is to make SSIDs for the iot and guest networks, and connect them with the respective network names.

Obviously restart after you've done made all the changes. If the guest and IoT networks don't work, that may be an indication that logical port 1 isn't actually the same as physical port 1 on the Netgear. You can look at the swconfig page in LuCI to see which port corresponds with the two new VLANs (tagged).