Dumb AP configuration on Archer C60

quick question:

In this mode, I'm finding something odd.

Using the wan port and the AP getting ip through the router dhcp, I bridged the wifi and the lan. I get access through the wifi (ip from the router and all0, but lan ports seem to be dead. am I missing something?

Reset and start from scratch, follow https://openwrt.org/docs/guide-user/network/wifi/dumbap

The thing is that I want to use all the ports, WAN and LAN ports plus the WLAN.

For unknown reason, I'm only getting WAN and WLAN to bridge, but LAN seems isolated.

If anyone can see the issue, please, could you give me a hand?

c

onfig interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd95:0998:4a6e::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        option stp '1'
        option ipv6 '0'
        option igmp_snooping '1'
        option acceptlocal '1'
        list ports 'eth0'
        list ports 'eth0.1'
        list ports 'eth1'
        option ifname 'eth0.1 eth1' #May24200

config interface 'lan'
        option device 'br-lan'
        option proto 'dhcp'
        option delegate '0'
        option force_link '1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config device
        option name 'wlan0'
        option ipv6 '0'

config device
        option name 'eth1'
        option ipv6 '0'
        option multicast_router '1'
        option multicast_fast_leave '1'
        option rpfilter 'loose'
        option acceptlocal '1'
        option multicast_to_unicast '1'

config device
        option name 'eth0'
        option ipv6 '0'
        option rpfilter 'loose'
        option acceptlocal '1'
        option multicast_router '1'
        option multicast_to_unicast '1'
        option multicast_fast_leave '1'

config device
        option name 'eth0.1'
        option type '8021q'
        option ifname 'eth0'
        option vid '1'
        option ipv6 '0'
        option acceptlocal '1'
        option multicast_router '1'
        option rpfilter 'loose'
        option multicast_to_unicast '1'
        option multicast_fast_leave '1'

config device
        option name 'wlan1'
        option ipv6 '0'
        option multicast_router '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1 2 3 4 5t' #May242022

Reset your device again because I think there are a bunch of issues with the current config that are not worth fixing (defaults work better as a starting point)... then post the default config of the network config file. From there, we can easily show you the change that should be made to allow the WAN port to perform just as another switched LAN port.

Alright, just wiped the router and here it is the default config, again, just want to use it as an AP but having all (WAN and LAN) ports available too:


root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd16:c016:991a::/48'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

Remove the two wan stanzas below:

then add eth1 to br-lan so that it looks like this

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'
        list ports 'eth1'

NOTE: it is possible that the throughput may be reduced since the physical wan port is actually an individually routed port, not part of the hardware switch. Throughput limitations happen because the bridge is a "software switch" which must go through the CPU, and the CPU is not optimized for switching (unlike the actual switch chip that is made specifically for this purpose). This means that you may see faster throughput between any 2 LAN ports than you will between any of the LAN ports and the WAN port.

1 Like

Could I make it so the bridge gets ip via dhcp like this? I commented out the old settings just in case someday I do more shenanigans:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd16:c016:991a::/48'

#config interface 'wan'
#        option device 'eth1'
#        option proto 'dhcp'

#config interface 'wan6'
#        option device 'eth1'
#        option proto 'dhcpv6'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'
		list ports 'eth1'

config interface 'lan'
        option device 'br-lan'
		option proto 'dhcp'		#option proto 'static'
								#option ipaddr '192.168.1.1'
								#option netmask '255.255.255.0'
								#option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

Yes. You can change the lan proto to dhcp.

You would not believe it...
But now the whole network is FASTER.

Thanks, thanks a lot.

Live long and prosper.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.