"Dumb AP" and IPv6

I have an OpenWRT router (19.07.2). My ISP offers IPv6, all is configured well and has been working. I don't use the router for wifi, I use a separate router as an access point. That router had been an older TP-LINK, and I was using its factory firmware (because, at the time, that worked better than OpenWRT on it). That was all set up pre-IPv6.

So, my OpenWRT router is properly configured for IPv6. It has quite a few DHCPv6 static leases set up, and I've basically identified all of the devices on my network and mapped them to addresses that I know. With the TP-LINK as the AP, this all just worked. The TP-LINK running as an AP didn't do anything at all with IPv6, it just bridged devices across the WiFi to the LAN, and the OpenWRT router happily provided RA and DHCPv6.

Now, I'm upgrading to a new Netgear 7800 as the AP, and I want to use OpenWRT as the OS on the AP. The problem I'm having is that now OpenWRT on the Netgear AP is too smart.

What I want is this: disable all IPv6 anything on the AP. Have the clients get their DHCPv6 from the OpenWRT router, not the AP. I want to manage everything in one place.

In other words, I don't want the AP to route anything. I just want it to be a dumb AP.

I've done this:


but that is conspicuously silent on IPv6, and I don't think that's enough.

So, the AP just has a single Ethernet connection into LAN port 4. Nothing's connected to the WAN port. WiFi is enabled. At first, the LAN Ethernet connection was grabbing a subnet from the primary router (because I have a /56 from my provider, and thus it could). I didn't want this behavior, so I have tried to kill all IPv6 on the AP. This is what I've done so far:

In Interfaces/LAN/General Settings, I set IPv6 assignment length to disabled. I have not set an IPv6 address manually (which means I can't connected to the AP itself over IPv6. I'm OK with this for now.)
In Interfaces/LAN/Advanced Settings, I disabled "Use builtin IPv6-management".
In Interfaces/LAN/DHCP Server/IPv6 Settings, I've set Router Advertisement-Service, DHCPv6-Service, and NDP-Proxy all to "relay mode". Master is unchecked.

Devices that connect to the WiFi on this access point get properly configured by SLAAC. They grab an IPv6 address and are properly configured for the router as their gateway.

However, they do not get a DHCPv6 address from the gateway.

Reading here:


I thought that "relay mode" would have been the proper choice here, but it doesn't seem to be.

What I really want is for the AP to literally do nothing with IPv6. I want it to just bridge all traffic across the wifi to the LAN, and let the router pick up the DHCPv6 request and respond.

What would the proper settings to accomplish this be?

Thank you,


Disabled. Relay mode is where you've got only a /64 and it's on WAN, so you want to relay NDP and RA from/to WAN. An AP is a layer 2 device it shouldn't do RA or anything.


Great. I swear I had tried setting all 3 to disabled and it hadn't worked, but I tried it again now and things seem to be working.

Can I make a humble suggestion that the "dumbap" page on the wiki may need to be updated to include those settings? While the "dumbap" page is sufficient for an IPv4 network, it may not be for an IPv6 network like this.



The OpenWrt project relies on volunteers, this includes maintenance of the documentation.
Why not register for the Wiki and add the missing information yourself?

1 Like

I can. I just wasn't sure if what I was saying was actually correct. I just kind of stumbled through getting this to work the way I wanted it to.