Dumb Access Point on TP-Link Archer A5

I have been trying to get a dumb access point set up on a TP-Link A5 running OpenWrt 23.05.0. I have followed many YouTube videos and the info in the OpenWrt users guide. When connecting to WiFi on the access poing, I cannot get an IP address assigned via DHCP from my main router. IP addresses are assigned fine on the physical ethernet ports. I have disabled dnsmasq, firewall, and odhcpd services on the dumb access point. Attached are the wireless and network config files from the access point. Thank you in advance for any help.

network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd1d:554c:50f8::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.99'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '99'
	option ports '6t 1t 2 3'
	option description 'LAN'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option description 'GUEST'
	option ports '6t 1t 4'

config interface 'GUEST'
	option proto 'dhcp'
	option device 'eth0.3'

wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/10300000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'access2.4G'
	option encryption 'psk2'
	option dtim_period '3'
	option key 'Password'
	option ieee80211r '1'
	option mobility_domain '123f'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'access5G'
	option encryption 'psk2'
	option dtim_period '3'
	option key 'Password'
	option ieee80211r '1'
	option mobility_domain '123F'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

this is not the recommend method... you should explicitly set the DHCP server for the lan to disabled (ignore) so that it cannot become reactivated as a function of a firmware upgrade (which will re-enable the dnsmasq service). But, the good news is that you have the device set to obtain an address via DHCP, so that will actually prevent the server from activating... still, best to use the ignore option in the dhcp server.

Set the guest network to unmanaged (proto none). If you intend to make this device broadcast the guest network as an SSID, you should be using a bridge. But that's not the issue with your current config.

I see a few things going on in the wireless config that I'd recommend you address:

  1. You haven't specified a country code. Be sure to do that on both radios.
  2. Disable/remove all of the 802.11r related items -- this can cause problems if not configured properly, and even when it is setup correctly, some devices just don't do well with this standard.

Next, please verify that you are indeed getting an IP address on all physical ports -- you should theoretically get an IP from the guest network on logical port 4 and on the main lan on logical ports 2 and 3. It's critical that we verify that these are all working properly.

Finally, on the main router, is there any MAC address allow/deny list or any other access restriction enabled? Is the DHCP pool large enough (it is possible that the pool is exhausted)?

MT7628 has a 16-vlan switch. Keep VLAN numbers under 16. If you really need packets tagged VLAN 99 to interact with something else, use this syntax:
config switch_vlan
option vlan 4 <-- Unique number that is between 1 and 15.
option vid 99 <-- Number 1 - 4094 that will be used in the packets.
option ports ...

2 Likes

I added the country code and turned off fast roaming. Not sure which one made the difference, but it is working now. Thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.