DuckDNS on my router

Hello, my question is: how to set up my router (SAGEMCOM f@st5260) with Duckdns?
Thank you.

mine guess your router already with openwrt?
the first part of the instructions are for people who want an easier install, but will accept http
if you want to use https, then you need to follow the further instructions
the wiki at http://wiki.openwrt.org/doc/howto/ddns.client may be helpful if you have issues
you must change your token and domain to be the one you want to update
we install the ddns packages

  • opkg update

  • opkg install ddns-scripts
    then setup the ddns-scripts

  • ddns-scripts

edit the config at /etc/config/ddns

config service "duckdns"
        option enabled          "1"
        option domain           "exampledomain.duckdns.org"
        option username         "exampledomain"
        option password         "a7c4d0ad-114e-40ef-ba1d-d217904a50f2"
        option ip_source        "network"
        option ip_network       "wan"
        option force_interval   "72"
        option force_unit       "hours"
        option check_interval   "10"
        option check_unit       "minutes"
        #option ip_source       "interface"
        #option ip_interface    "eth0.1"
        #option ip_source       "web"
        #option ip_url          "http://ipv4.wtfismyip.com/text"
        option update_url       "http://www.duckdns.org/update?domains=[USERNAME]&token=[PASSWORD]&ip=[IP]"
        #option use_https       "1"
        #option cacert          "/etc/ssl/certs/cacert.pem"

now start it up

**sh . /usr/lib/ddns/dynamic_dns_functions.sh # note the leading period start_daemon_for_all_ddns_sections "wan" exit**

we can now test the script by running the command

**/usr/lib/ddns/dynamic_dns_updater.sh duckdns**
if you want to use https - you will need to download Start SSL's ca bundle and install it
first we install curl and download the PEM file

**opkg update**
**opkg install curl**
**mkdir -p /etc/ssl/certs**
**curl -k https://certs.secureserver.net/repository/sf_bundle-g2.crt >  /etc/ssl/certs/ca-bundle.pem**

then you need to re-alter the config at /etc/config/ddns (uncomment these 2 lines)

        **option use_https       "1"**
        **option cacert          "/etc/ssl/certs/ca-bundle.pem"**

refer to the wiki on debugging etc http://wiki.openwrt.org/doc/howto/ddns.client

2 Likes

https://openwrt.org/docs/guide-user/services/ddns/duckdns

3 Likes

New URL: https://openwrt.org/docs/guide-user/services/ddns/client

The old page is for archival purposes only and does not receive updates any more.

2 Likes