Dsnmasq DHCP problem

Dear all,
PC connects to MIFI device by RDNIS interface.
After switching to ip passthrough from NAT mode.
The client(PC) can not obtain the correct from DHCP server at MIFI device.
any suggestion?

Dec 6 14:56:15 dnsmasq-dhcp[15993]: DHCP, IP range --, lease time 2
Dec 6 14:58:01 dnsmasq-dhcp[15993]: DHCP packet received on rndis0 which has no address

config dnsmasq

	option domainneeded '1'

	option boguspriv '1'

	option filterwin2k '0'

	option localise_queries '1'

	option rebind_protection '1'

	option rebind_localhost '1'

	option local '/lan/'

	option domain 'lan'

	option expandhosts '1'

	option nonegcache '0'

	option authoritative '1'

	option readethers '1'

	option leasefile '/tmp/dhcp.leases'

	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'

	option nonwildcard '1'

	option localservice '1'

	option logdhcp '1'

	option logqueries '1'

	option logfacility '/data/debuglog/wifi_log/dnsmasq.log'

config dhcp 'lan'

	option interface 'lan'

	option dhcpv6 'server'

	option dhcpv4 'server'

	option ra 'server'

	option leasetime '1m'

	option start '161'

	option limit '1'

	list dhcp_option '1,'

	list dhcp_option '3,'

	list dhcp_option '6,'

	list dns '2001:4546:0001:0000:0000:0000:0000:0001'

	list dns '2001:4546:0002:0000:0000:0000:0000:0001'

config dhcp 'wan'

	option interface 'wan'

	option ignore '1'

config domain

	option name 'mobile.hotspot'

	option ip ''

config odhcpd 'odhcpd'

	option maindhcp '0'

	option leasefile '/tmp/hosts/odhcpd'

	option leasetrigger '/usr/sbin/odhcpd-update'

	option loglevel '4'


option limit '1'

there only one IP addr to assign.

1 Like