DSL showing connected but no internet

Hi all

I'm trying to get going with OpenWRT on a HH5 but I seem to keep finding issues which is more than likely due to my lack of full understanding of OpenWRT at the moment.

I am running it as a modem router and it was working, albeit it was connecting slower than the Sky Q hub. Then I was playing with QoS and an adhole and things stopped. I decided to upgrade the router to the latest firmware and also reset it to factory settings. After doing that and configuring the router it shows the DSL is up but I can't access the internet from the LAN or WiFi and when I try and do anything in the Diagnostics it fails. For example on the ping it says Bad Address and if I ping 8.8.8.8 all packets fail. I've tried switching the firewall off to see if that would resolve anything but it didn't.

This is the status I'm getting on the overview screen:
Line State: UP [0x0]
Line Mode: G.993.2 (VDSL2)
Line Uptime: 8m 0s
Annex: B
Profile: 17a
Data Rate: 8.242 Mb/s / 798 Kb/s
Max. Attainable Data Rate (ATTNDR): 8.262 Mb/s / 1.169 Mb/s
Latency: 0.69 ms / 0.0 ms
Line Attenuation (LATN): 36.2 dB / 14.0 dB
Signal Attenuation (SATN): 26.8 dB / 14.0 dB
Noise Margin (SNR): 6.3 dB / 16.9 dB
Aggregate Transmit Power (ACTATP): 11.8 dB / 7.9 dB
Forward Error Correction Seconds (FECS): 0 / 0
Errored seconds (ES): 0 / 2
Severely Errored Seconds (SES): 0 / 0
Loss of Signal Seconds (LOSS): 0 / 0
Unavailable Seconds (UAS): 53 / 53
Header Error Code Errors (HEC): 0 / 0
Non Pre-emptive CRC errors (CRC_P): 0 / 0
Pre-emptive CRC errors (CRCP_P): 0 / 0
ATU-C System Vendor ID: Broadcom 164.154
Power Management Mode: L0 - Synchronized

Last week I also got a new Sky Q router which works happily and I've used Wireshark to get all of the new Client ID, Vendor ID and MAC, I've tried using the old ones and the new ones with no success.

Any advice would be greatly appreciated.

Thanks
Lyle

Check if your WAN connection is bound to a physical device, and that it is in the correct firewall zone

yep make sure in the interfaces section that your physical interface for the wan is dsl0

The physical interface should be dsl0.101 not simply dsl0. Most ISPs in the UK, including Sky, use VLAN ID 101 for their client services.

Also, for Sky, the WAN interface should be configured as DHCP Client not as PPPoE.

Thanks for all the quick responses, my interface is set to dsl1.101 however it is showing as a software VLAN, I didn't seem to have any other option in setting this up. Maybe this is my problem?

It is setup as DHCP Client.

Capture4

Everything seems to be well with your settings. What does your System Log say about the connection?

fwiw, as you have Sky, have you checked section 7.5 of the latest version of the installation guide for HH5A. Links to:
https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=1092&p=3068&hilit=sky#p3068

Sky and NOW use same settings
https://forum.openwrt.org/t/bt-homehub-5a-with-nowtv-fibre/50137/2

Bizarely I plugged in it again to try and get to the bottom of it again and this time it just worked, straight away :thinking:

I'm scared to touch anything now.

it was probably just the ISP ready to accept your connection after the lock on the old mac address expired