DSL not working on Fritzbox 3370

I didn't find anything in the forum or internet which solved my issue. So i hope somebody can give me a hint what i can do.

I have a running 7412 with Openwrt on my vdsl vectoring line from telekom. I want to replace it by a 3370 because of better wifi and usb ports.
However DSL does not come up at all.
I used the identical setup and dsl firmware which is working fine on the 7412. I also tried several other dsl firmwares, like the one supplied with openwrt, the latest which are included in the stock images of the 7412 and 3370 and the one from the DM200. I left it running for some period. But no luck. DSL stays down.
With the stock image it works perfectly. So hardware seems to be fine.

Edit 1:
I monitored the the Line State on the 3370:
It keeps cycling from 0x200 silent to 0x300 handshake to 0x380 full init to 0xff idle request to 0x200 silent.

Edit 2:
I used the vdsl_cpe_control command to dig a little. It seems it goes into an error (line state 0x1)
With "lecg" this exception is reported:
"nReturn=0 nErrorCode1=0x02 nSubErrorCode1=0x0E nFwErrorCode1=417 nErrorCode2=0x00 nSubErrorCode2=0x26 nFwErrorCode2=65535"

Any ideas what could be wrong?

Ok, I got a second 3370 and it worked out of the box with the DSL firmware.

The differences between the two boxes is that the new one is HWRevision 5 and the non-working one HWRevsion 3. Also the chipset seems different the new one reports "xRX200 rev 1.2" while the old one "xRX200 rev 1.1".
However, I think the magic is to understand the parameters one can feed to the dsl firmware, since with stock image both are running fine. Also AVM seems to do a lot of tweaking on this site.

Perhaps somebody can link this thread to the openwrt wiki page to prevent others to run into the same issue.