DSL and IPv6 for newbies

Hi, sorry for bringing up this topic again, but I read a lot of wiki pages and forum posts, but I seem to lack the overview (and experience) in the IPv6 topic and how to deal with it at a SOHO environment.

While my OpenWRT router assigns IPv6 addresses to LAN clients, this are local adresses only and LUCI doesn't show a ipv6 address of WAN nor WAN_6 interface. So I guess I don't receive a IPv6 assignment from my ISP and could not delegate it to my clients?

# ip -6 address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80::211:22ff:fe33:4455/64 scope link 
       valid_lft forever preferred_lft forever
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fdf0:6486:81a1::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::211:22ff:fe33:4455/64 scope link 
       valid_lft forever preferred_lft forever
6: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::3246:9aff:fe39:a1a0/64 scope link 
       valid_lft forever preferred_lft forever
7: dsl0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::200:1ff:fe00:0/64 scope link 
       valid_lft forever preferred_lft forever

I read about some extra steps for PPoE dialups and the firewall for DHCPv6 but didn't managed it to fixit. I guess I don't understand how everything fits together :thinking:

It doesn't look like you receive anything from your ISP.
What is your configuration and what has your ISP told you to do?

Here is a working config (/etc/config/network) for Rostelecom in Russia, on a Buffalo WBMR-HP-G300H:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config atm-bridge 'atm'
	option vpi '1'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'
	option vci '50'
	option unit '0'
	option atmdev '0'

config dsl 'dsl'
	option annex 'a'
	option firmware '/lib/firmware/dsl_ar9_firmware_adsl_a-04.05.04.09.01.01.bin'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ipaddr '192.168.3.1'

config interface 'wan'
	option ifname 'dsl0'
	option proto 'pppoe'
	option ipv6 '1'
	option username 'myusername'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	option peerdns '0'
	option keepalive '60 5'
	option password 'yaPassword'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

This results in the following addresses:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:24:a5:bd:40:22 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::224:a5ff:febd:4022/64 scope link 
       valid_lft forever preferred_lft forever
3: ifb0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN qlen 32
    link/ether 82:23:fa:9d:72:be brd ff:ff:ff:ff:ff:ff
4: ifb1: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN qlen 32
    link/ether 0e:76:b0:1f:ba:9b brd ff:ff:ff:ff:ff:ff
11: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 00:24:a5:bd:40:22 brd ff:ff:ff:ff:ff:ff
    inet 192.168.3.1/24 brd 192.168.3.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 2a01:540:42b:6000::1/64 scope global dynamic 
       valid_lft 50558sec preferred_lft 50558sec
    inet6 fe80::224:a5ff:febd:4022/64 scope link 
       valid_lft forever preferred_lft forever
12: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 00:24:a5:bd:40:22 brd ff:ff:ff:ff:ff:ff
13: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 00:24:a5:bd:40:22 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::224:a5ff:febd:4022/64 scope link 
       valid_lft forever preferred_lft forever
14: dsl0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
    link/ether 00:00:01:00:00:00 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::200:1ff:fe00:0/64 scope link 
       valid_lft forever preferred_lft forever
17: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN qlen 3
    link/ppp 
    inet 212.220.216.224 peer 212.220.30.188/32 scope global pppoe-wan
       valid_lft forever preferred_lft forever
    inet6 2a01:540:2:9dc5:fdf1:85c8:1eab:6a80/64 scope global dynamic 
       valid_lft 2591568sec preferred_lft 604368sec
    inet6 fe80::fdf1:85c8:1eab:6a80/10 scope link 
       valid_lft forever preferred_lft forever