DSL 2470B F1 Wireless suddenly not working

I Updated few days ago my router to the beta 2 of 18.06 and the wireless simply stopped working.
Reverted to 17.01.5 but the wireless is still not working.
Tried the original firmware and the wireless simply works fine.

Tried to reset in every way, to flash even 15.05 but on Openwrt it doesn't start the wifi.

lsmod show that ath9k is correctly loaded.
No errors in dmesg.

lspci show the wifi device just fine
00:00.0 PCI bridge: Broadcom Limited Device 6328
01:00.0 Ethernet controller: Qualcomm Atheros AR5008 Wireless Network Adapter (rev 01)

Any ideas?
It worked just fine for years till yesterday.

Did you reset LEDE to defaults and reconfigure the router (and WiFi)?

Some users have issues upgrading from version 15 to versions 17 or 18.

Yes I have done the reset to factory on every version and manually reconfigured but the wifi command don't seem to populate /etc/config/wireless.
I also tried to recover the old working configuration from the backup with no results.
This on every version I tried (15.05 - 17.01.5 - 18.06rc2 - trunk)

the wifi is working fine on the original firmware so it's not broken.

i have found one with a similar problem here https://bugs.openwrt.org/index.php?do=details&task_id=1566