DSA vlans: if-counter not working

Hello!

I have a mt7621-device and since I enabled vlans, the interface counters seems increasing randomly and unproportional to the traffic.

Here is my relevant part of the config:

config interface 'lan'
	option proto 'static'
	list ipaddr '10.0.0.112/24'
	option device 'br-lan.1'

config interface 'wan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.0.1'
	option gateway '192.168.0.138'
	option device 'br-lan.10'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan4:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'lan4:t'

Any help would be appreciated!

Robert

I ran into it by chance: I switched off "Offloading" and accounting works normal.
Is there a way to use interface-counters with "Offloading"?

Robert

No, the offloaded traffic bypasses the kernel almost completely, it's never seen by the kernel and can't be accounted. That's the price for speed.