DSA: via netifd

Tried getting some simple configurations working on a mamba with the stanza syntax as per ML, which I understand is ready to be kicked around. Could not make anything I tried work (but the mamba can be interesting), wondering if anyone else has taken a stab. I see that nbd has another patch series in the pipe, perhaps that is needed, but needs refreshing to be applied.

There was a syntax change as per commit, but it seems that with push, something as simple as:

config device switch0
	option name 'switch0'
	option type bridge

config bridge-vlan
	option device 'switch0'
	option vlan '1'
	option ports "lan1 lan2 lan3 lan4"

should setup correctly.

@anomeome were you able to test this out?

I'm still waiting for things to settle a bit w.t.r the DSA config, but this seems much more ergonomic than the previous 21-lan script I was playing around with to try and get things working..

Read posts in PR4307, there are some working configs (apparently), but currently I would just modify config in vi (not with GUI). The following simple setup seems to setup correctly, but fails to actually work for me on a mamba.

/etc/config/network
...
config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'switch0.1'
...

config device
	option type 'bridge'
	option name 'switch0'
	option ifname 'lan1 lan2 lan3 lan4 wan'

config bridge-vlan
	option device 'switch0'
	option vlan '1'
	option ports "lan1 lan2 lan3 lan4"
#	option ports "lan1 lan2 lan3 lan4:t"
#	option ports "lan1 lan2 lan3 lan4:t*"

#config bridge-vlan
#	option device 'switch0'
#	option vlan '10'
#	option ports "lan1:t lan2:t*"

might just be me, I have not spent much time fire fighting.

1 Like