DSA switch led off (NETGEAR R8000, OpenWrt 22.03.3)


Is there a way to control the switch LEDs in DSA mode? I want to turn off LEDs (namely LAN1-LAN4 ports) on NETGEAR R8000 with OpenWRT 22.03.3.

I've been wondering the same for my Linksys E7350, but have been told that because of "DSA" (not even sure what that is, and if it is "Distributed Switch Architecture", then I'm not sure why it would interfere with LED control), I am not able to disable the LEDs on my Router.

Are you both referring to the LEDs on the board, or LEDs on the ports themselves?

If the board:

If ports themselves:

  • No - this isn't usually possible on most devices. This was also true before DSA.

Can you link/quote this post?

And yeah I am talking about the LEDs on the board (front of the device). I've gone into the settings for LEDs and marked all and set the default state to "off". Yet, they still are on regardless. On my old TP-Link Archer C50v3 it worked immediately upon applying the settings in the LED section, but on my Linksys E7350 they're just ignored, and I don't understand why and/or how DSA would interfere with the LEDs.

1 Like

I fixed it. There is one LED left on the front that keeps ever blinking that I cannot even choose as an option (or likely add manually), but the others I managed to turn "off", by using the "Timer" option instead of the "None" (Always OFF) option, and then setting the "ON" state time to 0 and "OFF" state time to 1.

On that device, the switch supports GPIO control, unlike most. Unfortunately, the way it interacts is that it does not blink on LAN-LAN traffic properly. Only WAN-LAN. This is why it was removed.

1 Like