DSA: Port gets deactivated if assigned to another bridge than lan (21.02)

Hi,

I use a Turris Omnia with OpenWrt.
Recently I upgraded to OpenWrt 21.02 by doing a new install purging all configuration and configure them manually (luci) after the install.

I have multiple separated networks (Guest, IoT, Lan...). Only two of these are routed to lan ports: Lan and IoT.
Using bridges I created both networks and assigned the lan ports to them.
As soon as I remove a lan port from the Lan-bridge and assign it to the IoT-bridge the link LEDs go dark and the port is "deaktivated".

As far as I understand it this is a different problem then the other reports on the forum (e.g. [Solved] DSA Multiple Networks on 21.02 not bridging to lan ports).

Does anyone have an clue what might cause this behaviour?

My network config:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fxxxxxxf::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'

config interface 'wan'
	option device 'eth2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth2'
	option proto 'dhcpv6'

config device
	option type 'bridge'
	option name 'br-IoT'
	list ports 'lan0'

config interface 'IoT'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	option device 'br-IoT'

config interface 'Guest'
	option proto 'static'
	option device 'radio1.network1'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'

That configuration looks pretty weird to me, have a look at https://openwrt.org/docs/guide-user/network/dsa/dsa-mini-tutorial for the concept(s).

1 Like

option type 'bridge' inside a config interface block is part of the old syntax, it is now wrong to use it. Remove that line.

Attach wifi interfaces to networks using option network within /etc/config/wireless. This means that the network defined in /etc/config/network may start out with no device, or a device which is an empty bridge. The wireless will be added later.

That's wired, I created the config using Luci followin Option 2 from https://openwrt.org/docs/guide-user/network/dsa/dsa-mini-tutorial

Guess I have to fall back to the cli...

Switch to a VLAN configuration, everything works fine so far.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.