DSA - bridged LAN on managed switch

Hello.

I've got DGS-1210-28 F2 revision flashed with latest stable OpenWrt version (21.02). I'm struggling to create simple bridged LAN. Currently I've got switch connected to router and all devices to this switch. Unfortunately I can't access devices only the switch itself, nor devices get assigned an IP address. I've read mini DSA tutorial however after creating br-lan device and choosing particular LAN ports and assigning br-lan device to LAN interface, it isn't still working.

I'm posting default config since I would like to know what is wrong from the beginning (only port lan3 is assigned from wan_vlan to lan_vlan so I can access it via ethernet cable). What I'm asking if someone can post example/solution how it should look and maybe what should I get rid of.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'XXXX:XXXX:XXXX::/48'

config device 'switch'
        option name 'switch'
        option type 'bridge'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config bridge-vlan 'wan_vlan'
        option device 'switch'
        option vlan '1'
        option ports 'lan1 lan10 lan11 lan12 lan13 lan14 lan15 lan16 lan17 lan18 lan19 lan2 lan20 lan21 lan22 lan23 lan24 lan25 lan26 lan27 lan28 lan4 lan5 lan6 lan7 lan8 lan9'      

config device
        option name 'switch.1'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'wan'
        option device 'switch.1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'switch.1'
        option proto 'dhcpv6'

config bridge-vlan 'lan_vlan'
        option device 'switch'
        option vlan '100'
        option ports 'lan1:t lan3'

config device
        option name 'switch.100'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'lan'
        option device 'switch.100'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

Thanks in advance.

@sang-ook
hi

it is unclear what you want to make
you want to pass trough dhcp from main router, so the switch is acting like switch ?
or you want to make cascaded routers

Currently I've got switch connected to router

1 Like

Hello,

Sorry for unclear explanation. I want to act switch like a switch (yes, passing traffic through dhcp from router to other devices and vice versa via this switch).

well
if you like to make SWITCH act like a SWITCH ...
then you don't need WAN and WAN6 ports

and you need to delete WAN zone from firewall
if i guess correctly, from your config, wan and wan6 are on vlan1
from this, i guess that vlan1 is in WAN zone, so no inbound traffic allowed