DSA and @ alias

can someone confirm whether DSA recognizes the @ symbol for aliasing interfaces or is that now ended with DSA.

Tks.

It works - tested with custom scripts for network, firewall, system (led) and wifi config post OpenWrt installation on Archer C6v3. You do mean something like uci set network.@interface[-1].proto=static, right?

I think OP refers to this.
In that case I am not sure how DSA is connected, as we are talking about network names.

I was trying to alias @vxlan0.4 but I could never establish a tunnel. Instead I had to create a 802.1q interface then bridge it to the br-lan.4 interface. I was able to establish a tunnel this way but it just seemed one extra step too many to create the 802.1q interface. I liked the old openWRT 19.x config where I could just alias the vxlan0 interface and use dot notation.

I am using 22.03.2 on a mi r4a.

This works:

config device
        option type 'bridge'
        option name 'brvx0'
        option ipv6 '0'
        list ports 'br-lan.4'
        list ports 'vxlan0.4'

config device
        option type '8021q'
        option ifname 'vxlan0'
        option vid '4'
        option name 'vxlan0.4'
        option ipv6 '0'

This doesn't work:

config device
        option type 'bridge'
        option name 'brvx0'
        option ipv6 '0'
        list ports 'br-lan.4'
        list ports '@vxlan0.4'

ok this works now so DSA supports @ alias network interface. Not sure why I couldn't get it working before but it works now. Just needed to check so I wasn't chasing my own tail.

config device
        option type 'bridge'
        option name 'brvx0'
        option ipv6 '0'
        list ports 'br-lan.4'
        list ports '@vxlan0.4'
1 Like