DS-Lite not working

Hi,

Trying to build ds-lite topology.
The target is to build this: -

Below my OpenWrt interfaces settings.


...

should add more settings ? or ds-lite package will take care of everything in terms of tunnels and firewall?
coz pinging from the host to the IP v4 host isn't successful.

I can share the /etc/config/network files if that helps.

Thanks
Ameen

B4 configuration
config interface 'loopback'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
option device 'lo'

config globals 'globals'
option ula_prefix 'fdab:620f:3d62::/48'

config interface 'eth0'
option proto 'dhcp'
option device 'eth0'

config interface 'eth2'
option ipa6ddr '2001:db8:0:1::1'
option proto 'dslite'
option peeraddr '2001:db8:0:1::2'
option encaplimit 'ignore'
option network 'ETH2'
option ip6addr '2001:db8:0:1::1'

config interface 'eth1'
option proto 'static'
option device 'eth1'
option ipaddr '10.0.0.2'
option netmask '255.255.255.0'

AFTR configuration

config interface 'loopback'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
option device 'lo'

config globals 'globals'
option ula_prefix 'fdab:620f:3d62::/48'

config interface 'eth0'
option proto 'dhcp'
option device 'eth0'

config interface 'eth1'
option device 'eth1'
option proto 'static'
list ip6addr '2001:db8:0:2::1/64'

config interface 'eth2'
option proto 'static'
option device 'eth2'
option ipaddr '192.0.2.1'
option netmask '255.255.255.248'