Can you elaborate please.
I noticed after posting. OP measurements needed.
For some reason my driver doesnât support BQL I see that intel drivers do
Provide the debug detail to asses damage? Cannot keep guessing towards eternity.
Again I will once Iâm back on my network at home lol. I was just trying to understand what you meant by your comment with the software qdisc. All software qdisc I have is the usual cake, fq_codel etc. been using it but doesnât really help a lot since I have packets dropping.
If anything with cake configured I experience more delay even with managed speeds down to a certain limit. Throughput is sacrificed over latency but it feels the opposite.
Yep, thats whi i want to see your config to blame your mistakes
Haha mistakes are normal in life. You live and you learn.
Yeah I try not to mess with too much. So far just edited buffer sizes for eth0. Decreased txqueuelen for eth0 to 5 just to see how it feels. Increased txqueuelen from 1000 to 2000 for wan port eth2
You undetstand that TX buffers have no impact at all on RX drops.
yes i figured that witht the name i was misreading when i was configuring. im just telling you the edits i made but i will be posting my config now
ubus call system board
cat /etc/config/network
cat /etc/config/dhcp
cat /etc/config/firewall
ifconfig wan
cat /proc/net/softnet_stat
{
"kernel": "6.1.57",
"hostname": "FriendlyWrt",
"system": "ARMv8 Processor rev 0",
"model": "FriendlyElec NanoPi R6S",
"board_name": "friendlyelec,nanopi-r6s",
"release": {
"distribution": "OpenWrt",
"version": "23.05.5",
"revision": "r24106-10cc5fcd00",
"target": "rockchip/armv8",
"description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
}
}
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.x.x'
option netmask '255.x.x.x'
config globals 'globals'
option ula_prefix 'fd00:xx:xx::/xx'
config device
option name 'eth2'
option macaddr '8e:94:49:xx:xx:xx'
config interface 'wan'
option device 'eth2'
option proto 'dhcp'
option peerdns '0'
list dns '1.1.1.1'
list dns '1.0.0.1'
config interface 'wan6'
option device 'eth2'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
option peerdns '0'
list dns '2606:4700:4700::1111'
list dns '2606:4700:4700::1001'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1'
list ports 'eth0'
config device
option name 'eth1'
option macaddr '8e:94:49:xx:xx:xx'
config device
option name 'eth0'
option macaddr '8e:94:49:xx:xx:xx'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.x.x'
option netmask '255.255.xxx.x'
option ip6assign '60'
list dns '1.1.1.1'
list dns '1.0.0.1'
list dns '2606:4700:4700::1111'
list dns '2606:4700:4700::1001'
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'
option confdir '/tmp/dnsmasq.d'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option fullcone '0'
option flow_offloading '0'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option fullcone4 '1'
option fullcone6 '1'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fexx::/xx'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config rule
option name 'Reject-IPv6'
option family 'ipv6'
option src 'wan'
option dest '*'
option target 'REJECT'
option enabled '0'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'wz1'
option src 'wan'
option src_dport '3074'
option dest_ip '192.xxx.x.xxx'
option dest_port '3074'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'wz2'
list proto 'tcp'
option src 'wan'
option src_dport '3075'
option dest_ip '192.xxx.x.xxx'
option dest_port '3075'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'wz3'
option src 'wan'
option src_dport '27015-27030'
option dest_ip '192.xxx.x.xxx'
option dest_port '27015-27030'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'wz4'
option src 'wan'
option src_dport '27036-27037'
option dest_ip '192.xxx.x.xxx'
option dest_port '27036-27037'
list proto 'tcp'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'wz5'
list proto 'udp'
option src 'wan'
option src_dport '4380'
option dest_ip '192.xxx.x.xxx'
option dest_port '4380'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'wz6'
option src 'wan'
option src_dport '27000-27036'
option dest_ip '192.xxx.x.xxx'
option dest_port '27000-27036'
ifconfig: wan: error fetching interface information: Device not found
00000027 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
00177a80 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 0007459a 00000000 00000000 00000001
0015c9a7 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00036c01 00000000 00000000 00000002
0014357b 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00033d80 00000000 00000000 00000003
002a91e4 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 000af77f 00000000 00000000 00000004
00197431 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00079ee1 00000000 00000000 00000005
001ce4f0 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 0007771c 00000000 00000000 00000006
0014214f 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00051628 00000000 00000000 00000007
You should ask friendlyelec about friendlywrt issues.
Probably carrying along a proof any packet was ever lost.
you know ive tried but their forums are literally dead. last post was from a year ago. ive been switching between firmwares though. was at openwrt rc version till i bricked my router so i had to roll back with fwrt.
at least have any other suggestions???
no wan intâŹrface in your output nor a sign of a single lost packet. Maybe YOUR commercial support sees it other way.
It appears you are using firmware that is not from the official OpenWrt project.
When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.
You may find that the best options are:
- Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
- Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
- Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).
If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.
yeah no lost packets after the edits i made but i will check back one i go back to openwrt rc4 for my r6s
Well, here is my suggestion let's look at the ethtool statistics output.
Also try to remember what the initial queue size was the system came configured with.
I think I found the issue. So by default for the nanopi r6s it has three ports. ETH0, ETH1, and ETH2. As labeled on the router itself, ETH1 and ETH2 can be lan or wan so you can use either or as a wan port (I donât know why itâs like that). So I reset back to defaults and checked if config and seen that my ETH0 lan was already dropping packets. So I went into ethtool -G and found out that both ETH1 and 2 were set at their pre set maximum buffer sizes which is 1024 rx and tx, but ETH0 was only set at half that which was 512 rx and tx. So I plugged in Ethtool -G eth0 rx 1024 tx 1024 into local startup and gave it a reboot. After the reboot I checked ifconfig once again and woila, no dropped packets coming from ETH0. On another note, my driver for eth1 and eth2 which is now kmod-r8125-rss isnât a bql enabled driver. In fact the regular r8125 or the rss driver of it arenât bql enabled drivers. I checked a website and the last realtek bql enabled driver was the r8139. Sucks that BQL is not included in many drivers. Wish there was a work around. And oh yeah ETH1 and 2 are both 2.5G port while ETH0, is a 1G port with a built in driver that is st_gmac
Just a nice coincidence, but there is a nice article of BQL's author explaining the principles: