Dropbear: server refused our key

Hi folks,
I´m trying to replace an old WRT54GS with a WRT1200AC.
The WRT54 is running Kamikaze 8.09.2 and the WRT1200 is on LEDE Reboot 17.01.2.
I´ve copied the /etc/dropbear/authorized_keys file from the old, to the new router, but it keeps saying "server refused our key" when I try to log in via ssh pubkey authentication.
The same key pair is working fine on different versions of OpenWRT from Kamikaze - Chaos Calmer.
What´s going wrong here?

Have you tried to copy the key "text" from the old file to the new?

I tried to use the webui to copy the text from the old to the new router as well as copying the file via Winscp.
Same result. In the logfile I see: "Pubkey auth attempt with unknown algo for 'root' from IP-Adress:Portnumber"


maybe your key uses an old algorithm.

Already found that one, but didn´t believe that dsa support isn´t integrated in dropbear anymore. Will be a lot of work to change the key on all the routers and servers that I´m maintaining. Probably better to install chaos calmer on this one.
Thanks for your help anyway.

I found another thread on that:

Seems I have no choice and must replace my key-pair by a new one.
Maybe this helps others, that ran into the same problem.