Dropbear not enabled

Not sure if anyone else has run into this, but latest stable build does not have dropbear enabled by default.
I am running x86 on an i5-2400. Had to enable in Luci, then ssh in.

Would you mind running
logread|grep dropbear
and pasting the result?
I came across a similar problem recently testing x86 trunk builds in VM, due to dropbear failed to start before netifd could properly startup and init network ifaces.
Workaround: tune down dropbear startup script priority to make sure dropbear start behind netifd.
I don't know if you are having the same issue. Hope it helps.

********* is this what you are looking for?*********
********my concern is sometimes I checkout trunk, if I flash and cannot ssh in, I am fooked :slight_smile:

BusyBox v1.28.3 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt 18.06.0-rc2, r7141-e4d0ee5af5
root@OpenWrt:~# logread|grep dropbear
Wed Jul 18 22:03:37 2018 authpriv.info dropbear[1851]: Not backgrounding
Thu Jul 19 00:43:42 2018 authpriv.info dropbear[24195]: Child connection from xxx.xxx.x.xxx:52629
Thu Jul 19 00:43:49 2018 authpriv.notice dropbear[24195]: Password auth succeeded for 'root' from xxx.xxx.x.xxx:52629

Look good to me.

In my case, an entry of "interface br-lan has no physdev or physdev has no suitable ip" was logged. It worked fine on my other soc routers with same code revision though.

And this issue has disappeared as of r7519.
Dropbear is enabled by default unless you choose OpenSSH as a replacement at build time.

I understand your concern, however, x86 builds do not depend on dropbear as long as you have a keyboard and a display attached to start a console session.

Of course, on soc routers, unless you can make custom trunk builds with luci or you have fail-safe bootloader, things will go nasty if dropbear do not come up.

To further dig into this issue, a fresh install of openwrt, then if you still cannot ssh in, log in luci or start a console session to check system log to see what prevents dropbear from startup.

will do, tx very much.