Driver VLAN with Wifi on a single port device Fritz 1200

Hello, I am having a hard time configuring my Fritz Repeater 1200, that I want to use as a dumb accesspoint. I have successfully managed to install OpenWRT 21.02, but I am running out of ideas where my mistake is when configuring the network, especially the VLAN.

Here is my /etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxx

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	option macaddr 'xxx'
	option vlan_filtering '1'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '9'
	option name 'eth0.9'

config device
	option type 'bridge'
	option name 'br-GUEST'
	list ports 'eth0.9'

config interface 'GUEST'
	option proto 'none'
	option device 'br-GUEST'

Here is my /etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/soc/a000000.wifi'
	option htmode 'HT20'
	option disabled '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'X'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'platform/soc/a800000.wifi'
	option htmode 'VHT80'
	option cell_density '0'
	option country 'DE'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Y'
	option encryption 'none'
	option network 'GUEST'

What I am trying to do:

This device is connected via LAN to my pfsense router. The pfsense box is gateway to the internet and serves DHCP.

The Fritz 1200 should bring up two different wifinets, X and Y.

When clients connect to the X-wifi, their packets to my pfsense router should not have any VLAN-tag.
Packages, that my pfsense router sends to the Fritz 1200 without any VLAN-tag (untagged) should be receivable by the clients connected to the X-wifi.

When clients connect to the Y-wifi, their packets to my pfsense router should have the VLAN-tag 9.
Packages, that my pfsense router sends to the Fritz 1200 with VLAN-tag 9 should be receivable by the clients connected to the Y-wifi.

When I am trying to connect to the Y-wifi, my client does not even get an IP. The pfsense router doen not even show an incoming dhcp request...

I am running this setup successfully on other devices which are switch-capable. Obviously this FRITZ 1200 is not, so I am in need to create a driver-based VLAN. This seems to be where I made a mistake, but I do not see where. Additionally, I am not familiar with the new topology of "interface" and "device". Maybe I got confused there, too.

Any help is really appreciated. Thank you in advance.

I managed to configure my device. Thanks.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.