Driver-level VLAN not connecting to gateway

Following these instructions, I am trying to set up my repeater (AVM Fritz 1750E). It has only 1 LAN port, but 2 radios.

The LAN part is working. The WAN part cannot connect to the gateway (ping failed too). The gateway router is a Fritzbox 7490 with stock firmware.

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'foo bar'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.50.1'
	option gateway '192.168.100.1'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '1'
	option name 'eth0.1'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '2'
	option name 'eth0.2'

config interface 'wan'
	option proto 'dhcp'
	option device 'eth0.2'

config interface 'wan2'
	option proto 'dhcp'
	option device 'eth0'

WAN2 is only for testing and works.

root@OpenWrt:/etc/config# cat wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'psk2'
	option key 'abc'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'psk2'
	option key 'abc'

What is this LAN port connected to? You need a VLAN aware device upstream - either a managed switch or another device that works with 802.1q tags. if your 1750E is connected to directly to the Fritzbox 7490, does the 7490 with the stock firmware have user-level support for VLANs?

1 Like

Thank you.

My current setup is: Fritzbox 7490 as Modem/Router <--> Unmanaged Switch <--> (Patch Panel) <--> My Devices, e.g. 1750e

As far as I know, the Fritz is not VLAN aware.

For now I disabled the wan interface and only use wan2 (eth0). I hope this has no negative side effects.

So, you need to replace the unmanaged switch with a managed one in order to use VLANs.

Your problem is not with OpenWrt, but rather the rest of your network infrastructure. Your VLANs on OpenWrt don't have anywhere to go because you don't have 802.1q support anywhere else on your network. In particular, a managed switch is required to handle the tags and switch the networks through to the desired ports (typically the ports with regular devices connected would be access ports, meaning they carry just a single untagged network).

If you happen to have another OpenWrt router with a built-in switch, you can usually use that as a basic managed switch. Otherwise, you will need to replace your existing switch with a managed unit.