Drive vlan tagging + unmanaged switch + tp-link eap 245

So I have a dumb switch connected to my 8devices Jalapeno and one of those devices is the TP-Link EAP245 v3, which has a feature called Wireless VLAN, my assumption is looking for this is to match a tag I would set on my router.

So my config I have for the new device is as follows:

config interface 'IDIoT'
        option type 'bridge'
        option ifname 'eth0.107'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '64'

However in testing I have Wireless VLAN set to 107 on the AP and through the eth I have it set to 107, but I am unable to get a IP address when I connect, also I have put this under the lan firewall rules and enabled DHCP for this device.

Here is a screenshot of the setting in my tp link controller software.

Any thoughts on what I am missing?

I've not tried the Wireless VLAN option on my EAP245, but I suspect that sticking a dumb switch between the router and the EAP isn't going to work out. Have you tried connecting them directly?

I think a smart switch will pass the vlan tags from what I am reading, I think I will just go with this switch to test. I need the PoE anyways since I do not want to use the injector anymore when we move.

I have the non-PoE version of that switch and it supports VLANs just fine.

I just wanted to reply to this as I found some other solutions but not openwrt related.

I have a opnsense install I spun up and did a vlan of the number I wanted and connected to my wireless with wireless vlan set also and this is working through my current switch.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.