Dragino LG308 forwarding cellular UMTS/LTE connection to lan-port

Hey everyone,
I’m running a Dragino LG308 with a cellular 4g connection and it’s working fine. If I connect with putty I can ping google. So the cellular connection is working.
Now I would like to share this internet connection with a PC that is connected on the lan port. This pc is getting a IP-address and I can access the web interface of the router. But there is no internet connection.
I think there is no connection between the „cellular“ interface and the „lan“ interface at the moment.
Following I copied the network config and the prompt of ifconfig.
Is there any way how I can connect the interfaces so that my pc can use the cellular internet connection? Oh, and I think there is no openWRT web-interface. So, everything should be configured by command line :see_no_evil:
Thanks for your help :slight_smile:

in /etc/config/network i found:

root@dragino-1cfee8:~# vi ../etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option dns '8.8.8.8'
        option netmask '255.255.255.0'
        option ipaddr '10.130.1.1'
        option gateway '255.255.255.255'
        option ifname 'eth0'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth1'
        option hostname 'dragino-1cfee8'

config interface 'wwan'
        option proto 'dhcp'

config interface 'cellular'
        option proto '3g'
        option device '/dev/ttyUSB2'
        option ipv6 'auto'
        option dialnumber '*99#'
        option service 'umts'
        option backup '1'
        option apn 'iotde.telefonica.com'

ifconfig shows:

root@dragino-1cfee8:~# ifconfig
3g-cellular Link encap:Point-to-Point Protocol
          inet addr:10.43.117.106  P-t-P:10.64.64.64  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:2312 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2339 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:141354 (138.0 KiB)  TX bytes:205606 (200.7 KiB)

br-lan    Link encap:Ethernet  HWaddr A8:40:41:1C:FE:EB
          inet addr:10.130.1.1  Bcast:10.130.1.255  Mask:255.255.255.0
          inet6 addr: fe80::aa40:41ff:fe1c:feeb/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18097 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11413 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2019931 (1.9 MiB)  TX bytes:3557237 (3.3 MiB)

br-lan:9  Link encap:Ethernet  HWaddr A8:40:41:1C:FE:EB
          inet addr:172.31.255.254  Bcast:172.31.255.255  Mask:255.255.255.252
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

eth0      Link encap:Ethernet  HWaddr A8:40:41:1C:FE:EB
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18015 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11499 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2262694 (2.1 MiB)  TX bytes:3568393 (3.4 MiB)
          Interrupt:5

eth1      Link encap:Ethernet  HWaddr A8:40:41:1C:FE:EA
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:82 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:6192 (6.0 KiB)  TX bytes:6192 (6.0 KiB)

wlan0     Link encap:Ethernet  HWaddr A8:40:41:1C:FE:E8
          inet6 addr: fe80::aa40:41ff:fe1c:fee8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:141 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1969 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:16658 (16.2 KiB)  TX bytes:650593 (635.3 KiB)

In Lan interface, this is wrong, remove it.

I cannot tell what else is wrong, but verify that you have the cellular interface in wan firewall zone. That should do it.

1 Like

I removed the wrong entry, but that hasn’t solved the problem.

In the end I tried an older firmware (dragino-LG02_LG08--v5.3.1585192026-squashfs-sysupgrade.bin) from the distributor. That version has an older interface and there it was possible to configure the firewall and forwarding settings. Now it’s working fine.

@trendy thanks for the hint with the firewall settings and hopefully this can help someone else in the future as well.

I will contact the distributor as well. Maybe they can bring back the firewall and forwarding options in the new UI.

You overcomplicated things.
Adding the cellular interface to wan zone would be enough.
The test rules you have there are 1) wrong (it is security problem to open the lan from the internet) and 2) not needed (it is covered by forwarding rule).

1 Like

Oh, ok. I will test this tomorrow. Thanks :+1:

I only added the cellular interface like the wan interface which was already there. Now it's working fine :partying_face:
I haven't touched any forwarding rules. Now it looks like the pictures below. @trendy these rules where defined by default. Are they okay? Sorry I'm not so experienced with the network topic :see_no_evil:

I was referring to these rules.
Anyway it can work like this too, it's just more complicated.

1 Like

@trendy finally understood your solution, and yes, it was way easier. Thank you very much. You helped me a lot :wink::+1:

If some is using the new Dragino UI (FW 5.4) you can add 'cellular' to the firewall by hand.
/etc/config/firewall:

config zone
 option name 'wan'
 ...
 list network 'cellular'
 ...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.