Download speed limited to 27mbps. Need help!

I have TP-Link WR902AC V3 with OpenWrt 19.07.4 in client mode on 5GHz band, my download speed is limited to around 27mbps and upload to around 70mbps when the actual speed from the ISP is around 100mbps both up and down. I have managed to fix it many times (atleast temporarily) by messing around with the wireless settings. But the problem always comes back. What I have done :

  1. Changing channel width from 80MHz default to 40MHz.
  2. Using the option "Force 40MHz".
  3. Changing the country to 00 - World.
  4. Changing the operating mode to AC, N, Legacy.
  5. Changing the channel to what my ISP runs at (channel 116) and to auto.
  6. Un-checking the option "Disassociate On Low Acknowledgement".
  7. Un-checking the option "Allow legacy 802.11b rates"

I have played around with most of the option that I think could potentially causes the problem and I pretty much have ran out of ideas. What do you think the problem is? I am beginning to think that Openwrt just doesn't run well on this router. I also initially did not have QoS/SQM installed, I do now but I haven't touched any settings there, so this wouldn't be the problem.

I'd be very glad if anyone can help me. This is really frustrating. Thanks.

so show us the speeds your getting with stock firmware...

most of the things you changed are not relevant in client mode...

1 Like

I flashed Openwrt pretty much right away because the stock firmware has limitations such as limited number of wireless channels. I think there are only around 5 channels default and my ISP's channel 116 is not one of them.

But I managed to fix it again by changing the channel width to 20MHz, apply settings and changing it back to 40MHz but I am sure this will not be a permanent fix and the problem will come back eventually.

This guy in the link seemed to have the same exact problem as mine. His solution was to change to DD-WRT but my router isn't supported by DD-WRT unfortunately. lol.

You try to turn on MT76xx hwnat to see if there is any difference?

Are you talking about this? (I'm a noob) If yes, I turned it on too but doesn't help either. I forgot to mention this in the first post.
Screenshot (311)

Just enable hardware flow-offload on Mediatek based router, don't enable software flow-offload, and do you have SQM feature enabled?

If I disable software flow offloading, then hardware flow offloading disappears :confused: Screenshot (312)

Nope, as stated in the first post I don't have SQM enabled.

what is happening is that your wireless environment is influencing how your connection operates...

notice patterns with time/day?

you need to watch the adapter and compare the runtime state across operating conditions...

Next time this happens, instead of tweaking settings try to restart the wireless interface via Luci. You can even automate it via cron on a timer if need be.

Not really, I however did not try to either. The other day, simply enabling the 2.4GHz band triggered it. I love to play around with routers but this one, I'm afraid to do so. I probably can recreate the problem again by changing some settings. Do you think this has more to do with the environment rather than the router itself?

Never tried to restart the wireless interface alone (I will next time) but I have restarted the router a lot of times when the problem happens which usually did not fix the problem. I wonder what causes this to happen.

The problem is back after approx 26hrs uptime. And restarting the wireless interface doesn't fix it unfortunately.

Oh, I didn't notice that option has changed in the new version, sry.

Please clarify more about your configuration:

  • do you configure the router to relay the wifi from the isp & playback it on the same router ?
  • Are you measuring speedtest from a wired or wireless device ?

Try disabling the wireless AP feature, plug a PC directly into the router and run speedtest again to make sure the issue is not from your isp.

I suggest to test LAN to Router Performance with iperf3 to compare if this is a WIFI issue or a Internet routing issue.

What rate mode is showing for your wireless client? You can see the rates for each client on the wireless page in the web interface. Does this happen on all wireless clients or just one client device?

I have an Intel 6235 wireless card that always uses a very slow download rate when connected to recent versions of Openwrt, so maybe it's a similar issue for you.

Yes, basically I use my router as a wifi receiver to receive wifi from my ISP. And my router is wired to my PC. AP is not enabled. To make sure it's not the ISP issue, I simply connect my phone to the ISP's wifi and do a speedtest again, and I'm getting more than 100mbps. My phone is sitting next to my router when the test is done.

Screenshot (316)
Is this what you're talking about?

Thanks all of you by the way for the replies.

Does my reply to leeandy answer your question as well? I will need to learn to use iperf first :smile:

Not really that shows just your connection rate not what you actually get trough there. just install iperf3 via opkg