Download speed is slow, upload if faster

Hello.

I have installed latest version "openwrt-23.05.4-x86-64-generic-ext4-combined" on VirtualBox.

Everything works great except download speed on CLIENT side.

Download speed is 300 Mbit/s but it is should be 500 Mbit/s..
Upload speed is 106 Mbit/s which is higher then normal 100 Mbit/s.
Testing via wired cables which can handle up to 1 Gbit/s.

IPv6 is turned OFF on all devices (network cards). Most settings are still set to default.

Steering is turned OFF. If I turn on download speed become worst (from 300 Mbit/s to around 70 Mbit/s). QOS has not been installed.

Latency - ping is OK.

Sometime i got an error related to firewall? Temporary I turned off firewall but still show sometimes.

Any idea?

1

Thank you.

Can you snip the error and post it?

# ubus call system board
{
        "kernel": "5.15.162",
        "hostname": "*****",
        "system": "*****",
        "model": "***** VirtualBox",
        "board_name": "innotek-gmbh-virtualbox",
        "rootfs_type": "ext4",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.4",
                "revision": "r24012-d8dd03c46f",
                "target": "x86/64",
                "description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
        }
}
# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8c:7b13:b7c6::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        option ipv6 '0'
        option multicast '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '******'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config device
        option name 'eth0'
        option ipv6 '0'

config device
        option name 'eth1'
        option ipv6 '0'
        option multicast '1'

config device
        option name 'eth2'
        option ipv6 '0'

config device
        option name 'eth3'
        option ipv6 '0'

# cat /etc/config/wireless
cat: can't open '/etc/config/wireless': No such file or directory

# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option start '100'
        option limit '150'
        option leasetime '12h'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

# cat /etc/config/firewall

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option mtu_fix '1'
        option masq '1'
        list network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

Unknown error
3

1 Like

Speedtest via router without OpenWRT.
2

Try another openwrt flipping virtio_net to e1000 or vice versa.

1 Like

Hello.

I tried different combinations with "virtio_net" is worst.

1

Run speedtest from the router itself:
install speedtest-netperf then run

speedtest-netperf.sh -H netperf-eu.bufferbloat.net

Is the uplink NAT or bridge in virtualbox-es understanding?

Hello.

Problem it could be related with Virual Box and not Open WRT. I do several tests. When I was testing on Windows 10 (virtual box) speed test was worst around 80/80 Mbits. On main host still work with full speed when I don't running virtual boxes. When I running i think it reduce to 300 Mbits. It could be that problems are related only with virtual hosts due drivers, settings or something like that.

It is bridge. When I tried do speed via speedtest-netperf few days ago I didn't get speed test results. Only basic report when speed was missing.

I think I should first check VirualBox.

VirtualBox is used for testing purpose only.

Thank you for all!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.