Downgrading my firmware from 21.02 to 19.07

I upgraded my BT Home Hub 5A from 19.07 to 21.02 and moving through or changing settings is extremely slow in LUCI. The Router itself is okay, no major LAN or internet issues, just a pain making changes or checking configuration in LUCI.
My previous version of 19.7 LUCI was fine and I want to downgrade, using sysupgrade -n or flash 19.7 on from LUCI.
I have tried it once and could not access LUCI, only using CLI I could access the router and had to revert back to 21.02 to get it up and running.

Did you keep settings? If so, that is likely why you had the issue. Do not keep settings when downgrading. Likewise, it is recommended that you do not keep settings when upgrading, too (not always a requirement, but sometimes mandatory).

I did not keep the settings before, and I tried again and the problem is the same again.
The webpage says the usual about password not being set after a reset, but it won't allow login without a password. I can only access through CLI. I changed the password but it still won't allow me access.

Ah, the issue is likely due to the fact that 19.07 uses http by default, whereas if you upgraded from 19.07 > 21.02, it will enable https.

Clear your browser history and cache, and make sure you navigate to (not https)

1 Like

It was the cache causing problems

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.