Downgrading Archer C7 version 5.8 OpenWrt

I have purchased an A7 and C7 Archer AC1750 models. I can flash this file

Works great.

However, it breaks the code that we built to manage wifi access.

The only way I could fix this and have it work with our logic is to install

However, when I do this through tp-link, I get invalid file.

If I do this through TFTP, it seems to lock up the router and I have to go back to factory.

Does anyone know the lowest I could go in terms of openwrt or any trick to install a lower version?



It is possible to install OpenWrt over TFTP on this model. The same method also works for restoring back to the stock firmware.

Be a crazy dog, try the sysupg version (not the factory one), and tell us if didn't bricked the device! :smiley:


How would this help me downgrade from v22.03 to 17.06?

I already use TFTP to install through and it works but it gets bricked for anything other than version 22!!!

Very frustrating.


tried doing a reset post flash ?

After restoring the stock fw with tftp, you can flash your desired openwrt version, m8.


Regarding the invalide file, did you try to reduce the lenght of the filename, for example tot openwrt.bin? I had to do this on my achter c7.

I have flashed this thing so many times :).... I am officially a flasher.
I can restore to the stock firmware.
I have flashed version 17 using TFTP but it just brings up the router with the green light and it is stuck. I cannot reach it by IP.
What is m8?
I am going to try to reduce the bin name. However, I already flashed the system with the OpenWRT factory file and it won't work. The router just gets stuck.

1 Like

m8 is mate, mate - kwis? :smiley: :smiley: :smiley:

Hope you find a version what works. Note that the "factory" version seems to be used in the stock webgui of the router, not via TFTP.


I install the factory bin.
My only problem is after that.
I am going to install the factory bin and then go through tplink to flash the openwrt file with version 17 to see if it will work with a shorter filename. I am not holding much hope here because it has not worked using TFTP. I have no clue what to do :).

After I restore the stock fw with tftp, I get an invalid file error in tplink.

This is where I get the factory bin that works for me on TFTP. It takes me to tplink interface.

Then I go here

Click firmware and I can download the file.

That works for me to bring the router back to life :).

Now, not sure what to do. Going to try shortening the name here in 5 mins.

Cheers :).

Nada in the shortening the name of the file to go from 22.3 factory to 17.0.3.
Maybe if I install openwrt 22.3
Then I try to use openwrt to change the version?
I am lost.

From here seems that will be easier you rebuild your local user script that the new openwrt "broke". Also, a new firmware (and kernel) support a lot of new cool stuffs, like firewall4 instead firewall3.

I also dunno how to help, if the old desired version factory doesn't work. Maybe the new stock fw is preventing the openwrt install -- like, when factory.bin for v17 was made, the stock fw was an older version that allows openwrt install.

Maybe searching a really old stock fw version at your risk... but I would spend my time in that broke script.