Double pages for LuCI installation


#1

We currently have two pages for LuCI installation:

Anybody up for merging these two into one page?


#2

I'll take a look.

Edit: You can have a look at the merged page and let me know if something is missing.


#3

Looks good to me, although LuCI on nginx could use some clarification on the real support status for this option. If I read LuCI on nginx installation (18.06) correctly, this option is currently not supported.

@bobafetthotmail @richb-hanover-priv What do you think?


#4

At first glance, I hoped the page would have an introductory paragraph or two telling what it's about and who would care. (It also could remove/subsume those daunting WARNING messages that scare people off...) It might say:

Installing LuCI Web Interface

While OpenWrt can be managed completely using SSH and the terminal, the LuCI web interface makes many administration tasks easier.

The OpenWrt full releases, such as the current 18.06.x series, ship with the LuCI web interface installed. But for lower-memory devices, such as those with 4MBytes Flash and/or 32MBytes of RAM, the full install may fail because of lacking sufficient Flash memory.

You can obtain a copy of the build, and then use SSH by following these steps ...and tell how to get the build, etc...

I have not checked the remainder of the article. Thanks for taking this on!


#5

I've updated most of the links, but there're some left, which I have no access to edit:
https://openwrt.org/docs/guide-user/luci/luci.essentials-tomerge?do=backlink
Could you fix them please.