Double Nat Issue With Fibre

So heres my proble guys i have a

huawei echolife hg8242h (ONT Device) fibre to wan coversion
then a Dlink DIR-1960 running OpenWRT for my (PPPoE) ISP settings.

I cant seem to open ports to alow plex port fowarding through as i seem to be stuck behind a double NAT. Ive tried port fortwarding with no sucess even tried putting my dlink on the same Ip Subnet/network address as the Huawei ( Dlink ( With DHCP set to i have unPNP enabled firewalls off passthrough enabled DMZ enable to

Can Anyone offer some sugestions so i can get my plex server to be availible outside the network

It's the Huawei device you need to reconfigure 1st, if there are no firewall options in it, you're screwed, at least using ipv4.

If the PPPoE connection is being initiated by the OpenWrt router, then there is no double-NAT with the ONT. If the PPPoE connection does not give you a public IP address, then your ISP is using CGNAT, and there is nothing you can do locally.

EDIT: Fixed a typo... I should stop posting from my phone, if I am not wearing my glasses


Does your ISP use carrier grade Nat (here in the UK many newer fibre providers do). if so you are stymied unless they will give you a static IP