Does the "Disable inactivity polling" option work in OpenWrt 21.02.0?

I'm running the latest OpenWrt 21.02.0 and I have the "Disable inactivity polling" check box enabled. I even double checked my /etc/config/wireless settings and can confirm that option skip_inactivity_poll '1' is indeed present. Also, I don't think it is related but I will point out that I have option disassoc_low_ack '0' in my wireless config as well. All of that said, I'm still seeing this in my logs:

Wed Sep 29 10:25:49 2021 hostapd: wlan1: STA xx:xx:xx:xx:xx:xx IEEE 802.11: disassociated due to inactivity
Wed Sep 29 10:25:50 2021 hostapd: wlan1: STA xx:xx:xx:xx:xx:xx IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

It would appear as though the "Disable inactivity polling" option isn't working as expected.

The reason I spotted this is because devices connected to the 5GHz radio (MediaTek MT7615E) do not disappear from the Associated Stations table even after they disconnect. They have to get timed out to be removed. All devices connected to the 2.4GHz radio (MediaTek MT7603E) disappear from Associated Stations table immediately when they disconnect as one would expect.

Is the MT7615E driver not doing something it should be doing maybe?

Any feedback, input, insight, comments, etc would be greatly appreciated.

I do not have an answer for our question, just want to point out, that there are related discussions about technical issues: OpenWrt on MT7621/MT7615N devices with 5GHz problems

Thank you for pointing me to that thread. However, it doesn't appear related to the inactivity polling option working or not working though. Also, I haven't experienced any performance issues or any other problems like those in that thread (at least not yet anyway). What I am seeing is just a settings bug and/or a driver issue that doesn't do exactly what it should be doing.