Does PPPOE work properly for you in 23.05?

I think something wrong with PPPOE parsing in 23.05, at DHCP there is a default route. at PPPOE there is none. Does any of you got internet working with PPPOE? I think most countries use DHCP so not much PPPOE users.

It works with absolutely no problems on my AVM Fritz!Box 7520, using Deutsche Telekom VDSL.

Edit:
Maybe it's just a problem with your RT-N18U or your configuration.
I'm quite sure, if there is a bigger problem with PPPoE you'd have read about it weeks ago (since many people were / are using snapshots before switching to the official release).

4 Likes

Did you forget the thread you made 6 minutes before this one?

1 Like

They are not even damn related! Most people don't even use PPPOE; most countries use DHCP I assume? I am trying to find a solution myself. I am simply trying to assess if this is a damn hardware problem or a software problem! I am looking at statistics. If PPPOE works for most people, I'll assume this is a hardware problem, or kernel related( mostly very hard to solve). And I will leave your damn forum alone. Hardware problems are beyond me. But you admins kinda push people out. Ok you made some great software, I am thankful, I am willing to donate some, I might even help with coding, but with that attitude I may not. If you know someone who can help, I can pay him to help. But I am really bored of this attitude.

You're correct - cussing at me was unnecessary, I can see how it's boring. Wow.

I have no clue why you're upset, but perhaps someone who wishes to be cussed at can assist you. I hope the best for your issue.

3 Likes

I am sorry if I came too hard. But I am pulling my hair here and trying to solve this silently as I can, and without disturbing people. But I need to see if PPPOE works for people or not. If you will delete this, I am definitely never going to donate. I am being fair here. Already not many people use Openwrt, and with deleting my topic you will be disabling my only chance at getting the slightest help here. I don't ask for much, just trying to see if PPPOE works for people. Right?
I think in wiki you should edit that PPPOE users might have problems. Or can I edit though?

Feel free to keep asking - it's just not clear why you're mentioning deleting threads (I don't have that power) or refusing to donate. Or why you just didn't [calmly] note they were two different threads.

Again, I hope the PPPoE issue is resolved - thanks for clarifying that you're just inquiring if PPPoE is working for people in 23.05.0, I understand now.

No worries, I'm sure people are seeing the thread, testing, etc.

Works for me. Have you enabled "debug" in "/etc/ppp/options" yet?

1 Like

I have not enabled that, no. I suppose this is a thing to debug when PPPOE doesn't work? Would you care to elaborate?

I'm using PPPoE on my 200mbit GPON Fiber connection, no problems here, if you enable debug in PPPoE, you can see the logs like this and check where in the PPPoE handshake is failing

Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Send PPPOE Discovery V1T1 PADI session 0x0 length 12
 dst ff:ff:ff:ff:ff:ff  src 70:4f:57:b2:60:be
 [service-name] [host-uniq  00 00 0f ee]
Recv PPPOE Discovery V1T1 PADO session 0x0 length 46
 dst 70:4f:57:b2:60:be  src ac:1f:6b:a4:0b:4c
 [AC-name EXCITEL] [service-name] [service-name excitel] [host-uniq  00 00 0f ee] [AC-cookie  1b f6 af d6 04 88 ff ff]
Send PPPOE Discovery V1T1 PADR session 0x0 length 24
 dst ac:1f:6b:a4:0b:4c  src 70:4f:57:b2:60:be
 [service-name] [host-uniq  00 00 0f ee] [AC-cookie  1b f6 af d6 04 88 ff ff]
Recv PPPOE Discovery V1T1 PADO session 0x0 length 48
 dst 70:4f:57:b2:60:be  src cc:2d:e0:11:93:f6
 [host-uniq  00 00 0f ee] [service-name] [AC-name Jaihind online-Attapur] [service-name EXCELL]
Recv PPPOE Discovery V1T1 PADS session 0x8280 length 35
 dst 70:4f:57:b2:60:be  src ac:1f:6b:a4:0b:4c
 [AC-name EXCITEL] [service-name] [host-uniq  00 00 0f ee] [AC-cookie  1b f6 af d6 04 88 ff ff]
PADS: Service-Name: ''
PPP session is 33408
Connected to ac:1f:6b:a4:0b:4c via interface eth0.200
using channel 24
Renamed interface ppp0 to pppoe-wan
Using interface pppoe-wan
Connect: pppoe-wan <--> eth0.200
sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xc1704f23>]
rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0xc1704f23>]
rcvd [LCP ConfReq id=0x2 <pcomp> <mru 1492> <magic 0x16c0b948> <auth chap MD5>]
sent [LCP ConfRej id=0x2 <pcomp>]
rcvd [LCP ConfReq id=0x3 <mru 1492> <magic 0x16c0b948> <auth chap MD5>]
sent [LCP ConfAck id=0x3 <mru 1492> <magic 0x16c0b948> <auth chap MD5>]
sent [LCP EchoReq id=0x0 magic=0xc1704f23]
rcvd [CHAP Challenge id=0x1 <bb1e685bc8fed7a3f7bf4858ce79cbfcf8bce0bd7e2b78384cfb02bac1>, name = "6wind"]
sent [CHAP Response id=0x1 <bd6574691a8479e6a1daf2cd1601df67>, name = "udaikiran"]
rcvd [LCP EchoRep id=0x0 magic=0x16c0b948]
rcvd [CHAP Success id=0x1 "Welcome"]
CHAP authentication succeeded: Welcome
CHAP authentication succeeded
peer from calling number AC:1F:6B:A4:0B:4C authorized
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPV6CP ConfReq id=0x1 <addr fe80::d512:900e:6d7f:ae4e>]
rcvd [IPCP ConfReq id=0x1 <addr 110.235.224.1>]
sent [IPCP ConfAck id=0x1 <addr 110.235.224.1>]
rcvd [LCP ProtRej id=0x1 80 57 01 01 00 0e 01 0a d5 12 90 0e 6d 7f ae 4e]
Protocol-Reject for 'IPv6 Control Protocol' (0x8057) received
rcvd [IPCP ConfNak id=0x1 <addr 144.48.75.254> <ms-dns1 110.235.231.2> <ms-dns2 110.235.224.1>]
sent [IPCP ConfReq id=0x2 <addr 144.48.75.254> <ms-dns1 110.235.231.2> <ms-dns2 110.235.224.1>]
rcvd [IPCP ConfAck id=0x2 <addr 144.48.75.254> <ms-dns1 110.235.231.2> <ms-dns2 110.235.224.1>]
local  IP address 144.48.75.254
remote IP address 110.235.224.1
primary   DNS address 110.235.231.2
secondary DNS address 110.235.224.1
Script /lib/netifd/ppp-up started (pid 4131)
Script /lib/netifd/ppp-up finished (pid 4131), status = 0x1

And here is the non-working one. 
Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Send PPPOE Discovery V1T1 PADI session 0x0 length 12
 dst ff:ff:ff:ff:ff:ff  src 70:4f:57:b2:5a:ae
 [service-name] [host-uniq  00 00 4f 10]
Recv PPPOE Discovery V1T1 PADO session 0x0 length 46
 dst 70:4f:57:b2:5a:ae  src ac:1f:6b:a4:0b:4c
 [AC-name EXCITEL] [service-name] [service-name excitel] [host-uniq  00 00 4f 10] [AC-cookie  1b f7 05 50 04 88 ff ff]
Send PPPOE Discovery V1T1 PADR session 0x0 length 24
 dst ac:1f:6b:a4:0b:4c  src 70:4f:57:b2:5a:ae
 [service-name] [host-uniq  00 00 4f 10] [AC-cookie  1b f7 05 50 04 88 ff ff]
Recv PPPOE Discovery V1T1 PADO session 0x0 length 46
 dst 70:4f:57:b2:5a:ae  src ac:1f:6b:a4:0b:86
 [AC-name EXCITEL] [service-name] [service-name excitel] [host-uniq  00 00 4f 10] [AC-cookie  1b f6 cf 79 04 88 ff ff]
Recv PPPOE Discovery V1T1 PADO session 0x0 length 48
 dst 70:4f:57:b2:5a:ae  src cc:2d:e0:11:93:f6
 [host-uniq  00 00 4f 10] [service-name] [AC-name Jaihind online-Attapur] [service-name EXCELL]
Recv PPPOE Discovery V1T1 PADS session 0x8343 length 35
 dst 70:4f:57:b2:5a:ae  src ac:1f:6b:a4:0b:4c
 [AC-name EXCITEL] [service-name] [host-uniq  00 00 4f 10] [AC-cookie  1b f7 05 50 04 88 ff ff]
PADS: Service-Name: ''
PPP session is 33603
Connected to ac:1f:6b:a4:0b:4c via interface eth0.200
using channel 184
Renamed interface ppp0 to pppoe-wan
Using interface pppoe-wan
Connect: pppoe-wan <--> eth0.200
sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xfb4c855a>]
rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0xfb4c855a>]
rcvd [LCP ConfReq id=0x2 <pcomp> <mru 1492> <magic 0xeabe4074> <auth chap MD5>]
sent [LCP ConfRej id=0x2 <pcomp>]
rcvd [LCP ConfReq id=0x3 <mru 1492> <magic 0xeabe4074> <auth chap MD5>]
sent [LCP ConfAck id=0x3 <mru 1492> <magic 0xeabe4074> <auth chap MD5>]
sent [LCP EchoReq id=0x0 magic=0xfb4c855a]
rcvd [CHAP Challenge id=0x1 <bb1e686d4b3b75a5c1879becfd7e5820851bb69732c8600f17aa59ff865da74176eeb77e91a3d01765c2eddb4f>, name = "6wind"]
sent [CHAP Response id=0x1 <a3fdb413a8f170227456a7c15f4b9893>, name = "udaikiran"]
rcvd [LCP EchoRep id=0x0 magic=0xeabe4074]
sent [LCP EchoReq id=0x1 magic=0xfb4c855a]
rcvd [LCP EchoRep id=0x1 magic=0xeabe4074]
sent [LCP EchoReq id=0x2 magic=0xfb4c855a]
rcvd [LCP EchoRep id=0x2 magic=0xeabe4074]
rcvd [CHAP Failure id=0x1 "mac validation failed: c"]
CHAP authentication failed: mac validation failed: c
CHAP authentication failed
1 Like

Mate I am onto something, I think. It says Permission denied on some command:

Wed Nov  1 01:46:24 2023 daemon.notice netifd: wan (5059): Command failed: ubus call network.interface notify_proto { "action": 1, "command": [ "\/usr\/sbin\/pppd", "nodetach", "ipparam", "wan", "ifname", "pppoe-wan", "lcp-echo-interval", "1", "lcp-echo-failure", "5", "lcp-echo-adaptive", "nodefaultroute", "usepeerdns", "maxfail", "1", "user", "myISPdata@turk.net", "password", "mypass", "ip-up-script", "\/lib\/netifd\/ppp-up", "ip-down-script", "\/lib\/netifd\/ppp-down", "mtu", "1492", "mru", "1492", "plugin", "pppoe.so", "nic-wan.35" ], "interface": "wan" } (Permission denied)
Wed Nov  1 01:46:24 2023 daemon.notice netifd: Interface 'wan' is now down
Wed Nov  1 0

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
1 Like

As a side note, I checked on 22.03.05, on the interfaces>devices page, there is pppoe-wan(tunnel device). But 23.05 there is no pppoe-wan device. Only wan.35 recognized as 802.1q. I tried adding that manually but no, can't add that. No option as tunnel device. Anyway here is my /etc/config/network file:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'someipv6/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	option mtu '1500'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option delegate '0'

config device
	option name 'wan'
	option macaddr 'mymac'
	option mtu '1500'

config interface 'wan'
	option device 'wan.35'
	option proto 'pppoe'
	option username 'xxxx@turk.net'
	option password 'xxxx'
	option ipv6 '0'
	option mtu '1500'
	option keepalive '20 20' 
	option defaultroute '1'

config device
	option name 'wan.35'
	option type '8021q'
	option ifname 'wan'
	option vid '35'
	option mtu '1500'

It might be related to the vlan tag... The other reports also mentioned a vlan tag in their setup.

I can try setiing up a lab environment and see.

I suspect, in the GUI I set the device manually by writing "wan.35" there, and it automatically sets it up. Maybe it can't set that up anymore. We have to manually add 8021q by hand perhaps.

Even on fiber connections PPPoE is still used. I'm on fiber, coming from xDSL with the same provider, and they still stick with PPPoE. So yes, it is very common still, PPP is not just for antiquated dial-up connections.

And PPPoE has been working fine here all the way, been on 23.05 since it got branched off.

Can you post a bit more of your log file, i.e. the whole part where it tries to bring up WAN?

I would also remove all MTU settings for now and add them back in once the connection is established.

Could imagine that it ends up being "timeout waiting for PADO". There's some reported interop issues with DSA switches and PPPoE on some devices.

Okay here it is:https://justpaste.it/ahvfn
It's too long so I put it on that site. I removed the MTU thing and left it at the default values.
This is from a newly restarted device, so half of the logs are from booting etc.

That "permission denied" is harmless, it is just the result of trying to kill something that was already gone. That happened after the wan failed to connect, and OpenWrt was in the process of tearing everything down to start over.

The real problem is a bit before that, as expected here.

Wed Nov  1 02:04:00 2023 daemon.warn pppd[1883]: Timeout waiting for PADO packets
Wed Nov  1 02:04:00 2023 daemon.err pppd[1883]: Unable to complete PPPoE Discovery
Wed Nov  1 02:04:00 2023 daemon.info pppd[1883]: Exit.

This means there is no Ethernet traffic from the modem-- probably the VLAN is not working. Someone else had a similar problem with a Broadcom chip, I don't know if it was resolved.

You could try a more elaborate DSA configuration of wrapping all the ports in a bridge first:

config device
    option name 'br-lan'
    list ports 'wan'
    list ports 'lan1'
    list ports 'lan2'
... (all the ports, basically just add wan to the existing br-lan)

# VLAN 1 is the lan.  Note that the lan Device must be changed to br-lan.1
config bridge-vlan
    option device 'br-lan'
    option vlan '1'
    list ports 'lan1:u'
    list ports 'lan2:u'
... etc

config bridge-vlan
    option device 'br-lan'
    option vlan '35'
    list ports 'wan:t'

# Then use br-lan.35 as the wan device.

Be logged into to the router via wifi while setting this up, as Ethernet is likely to at least temporarily stop working.

If this doesn't work there are more drastic measures such as reconfiguring the ONT to not use a VLAN tag (even better to not use pppoe either) or if that is not possible inserting a managed switch between the router and the ONT strictly to apply / remove tags.