Does it works to link two different routers (wrt32x & miwifi mini) via WDS?

Hi guys, I try to extend my wireless network by two routers, with WDS link.

Router A: Linksys WRT32X, OpenWrt 19.07.2, main router
Router B: MiWifi Mini, OpenWrt 19.07.2

Through mass google search, some articles indicate that WDS needs the same wireless device support, but i want prove whether it works.

Follow the guide Atheros and MAC80211 WDS to implement a wireless network bridge (wireless repeater) , I reset and configured Router A as AP (Access Point), Router B as STA (Remote Wireless Station).

After reboot, both Router A and Router B can discover each other's MAC address at 'Associated Stations '(Network > Wireless) , look like that works. But problem is wired pc connected via Ethernet to LAN ports on router B can not obtain IP address automatically, so client of router B can not access router A (Main Router), even configured a static IP address.

This is my configuration:
Router A
/etc/config/wireless

...
config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT20'
	option channel '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr '62:38:e0:AA:AA:AA'
	option ssid 'WDS'
	option key 'PASSWORD'
	option ifname '2.4g'
	option wds '1'
	option encryption 'psk2'
...

Router A
/etc/config/wireless

...
config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option htmode 'HT20'
	option channel '1'

config wifi-iface 'wifinet2'
	option key 'PASSWORD'
	option ssid 'WDS'
	option device 'radio1'
        option wds '1'
	option mode 'sta'
	option bssid '62:38:e0:AA:AA:AA'
	option network 'lan'
	option encryption 'psk2'
...

I want to confirm does WDS work with this configuration. If not , may be i have to return to wire cable or change hardware.

For which interface on which device?

How about wireless clients of router B? And how about router B itself, does it have Internet?

Maybe you should also post network and dhcp configuration.

Hi mhegab,

It's the interface on Router B:
pc(static IP 192.168.1.100) ---wire--> Router B (interface lan 192.168.1.2) -- WDS --> Router A (192.168.1

Wireless client of router B can not assign ip address;
Router b's interface lan is static ip address 192.168.1.2;
If router b's interface lan is DHCP, can not assign ip address too, and
A can't ping B, B can't ping A.

I hava reset all config, i cannot sure is a hardware driver problem or config error.

Thanks for your replay @Hegabo.
Can you roughly judge whether this is a hardware problem or a software problem? If hardware, maybe , i can skip this scheme.

If the two routers can't communicate, the there is no point of trying to get the PC to have access before fixing that.

I don't know. I have WDS working between two QC/Ath devices.I haven't tried between different chipsets running OpenWrt, though @jeff seemed to believe it can run, provided the driver supports that WDS Compatibility? (I don't know if it does).

You may look into other options such as https://oldwiki.archive.openwrt.org/doc/recipes/relayclient, though don't expect the best results.

I've run ath9k (WDS client) against ath10k (WDS AP) and am still running ath10k on both ends (sorry, no personal experience with mt76 or mwlwifi), which is both working nicely. In general 4addr should be supportable (and interoperable) by all nl80211 based drivers, but mwlwifi is not a good example here (it has enough unfixed bugs to believe that 4addr might just be broken as well).

At least on WRT3200ACM WDS works just fine.

I would say it works "almost fine": when used as a WDS-AP, all traffic stops upon WPA rekeying.

It probably won't make a difference here, but setting your country code for the radio is always advisable.

1 Like