Does anybody using QCA9377?

I have one in Thinkpad x230 and speed is very slow both in client or master mode in ArchLinux latest. No more then 30-40 MBit/s

Well, its the worst QCA ac card.
Since its only Wawe-1 and 1x1, I would not expect to get more than you are getting.

1 Like

It's not normal. Even Intel 6200 AGN is about 3x time faster

I tried. Replaced a 2x2 ath9k card with a QCA9377. Changed back a couple of hours later. Even an RTL8821AE works better.

1 Like

By the way, I test QCA9377 in Windows10 and it perform nearer to hardware specs - up to 200 MBit/s. So Linux module ath10k or firmware is responsible for low results
The chip is not so bad

Is this a reference card or from one of the vendors?
If its not reference one then board caldata may be completely wrong

03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
Subsystem: AzureWave Device 2a51
Flags: bus master, fast devsel, latency 0, IRQ 34, IOMMU group 12
Memory at f0400000 (64-bit, non-prefetchable) [size=2M]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable+ Count=1/8 Maskable+ 64bit-
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [148] Virtual Channel
Capabilities: [168] Device Serial Number 00-00-00-00-00-00-00-00
Capabilities: [178] Latency Tolerance Reporting
Capabilities: [180] L1 PM Substates
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci

Well, then it's a custom one.
For windows you are using the generic driver or vendor provided?

I use generic, win10 worked in KVM

Well then I am out of ideas