Docker: Temporary failure resolving 'archive.ubuntu.com'

Looks like the container does no have network access. Here is what I am seeing and below is the relevant config: anyone sees any mis-configuration? docker0 interface is up.

Step 3/8 : RUN apt-get update &&     apt-get dist-upgrade -y &&     apt-get install -y         build-essential curl file gawk gettext git libncurses5-dev         libssl-dev python2.7 python3 subversion sudo swig unzip         wget wget2 zlib1g-dev tzdata htop vim rsync xterm         sudo build-essential subversion libncurses5-dev zlib1g-dev         gawk gcc-multilib flex git-core gettext libssl-dev python &&     apt-get autoclean &&     apt-get clean &&     apt-get -y --purge autoremove &&     rm -rf /var/lib/apt/lists/*
 ---> Running in 01ed3f3c46ea
Err:1 http://archive.ubuntu.com/ubuntu focal InRelease
  Temporary failure resolving 'archive.ubuntu.com'
Err:2 http://security.ubuntu.com/ubuntu focal-security InRelease
  Temporary failure resolving 'security.ubuntu.com'
/etc/config/firewall

config zone 'docker'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option name 'docker'
	list network 'docker'

/etc/config/network

config interface 'docker'
	option device 'docker0'
	option proto 'none'
	option auto '0'

config device
	option type 'bridge'
	option name 'docker0'
	option bridge_empty '1'