Docker-ce missing in repository on "snapshots"


I'm trying to setup and play with docker setup as a host on openwrt (especially on the Linksys 3200ACM).

It seems that a couple of days or weeks ago the docker-ce package disapreared from available package in the repos ?

Is there a place where we can eventually track build issue if it's what happen or if docker-ce is just not built anymore, is there a place we can look to have an history / explanation about it ?

Thank you !

ERROR: Expected 'PKG_SOURCE_VERSION:=dc9208a3303feef5b3839f4323d9beb36df0a9dd' in '../runc/Makefile', found 'PKG_SOURCE_VERSION:=ff819c7e9184c13b7c2607fe6c30ae19403a7aff'

normally something like this is a subset of packages feed @ github -> issues -> docker

its a fairly 'experimental' package... and depending on who the maintainer is, how busy they are etc... fixes can come at any pace ...


Thanks for the answer, links and explanations ! I've learned where to look in case I suspect a build issue with a package :slight_smile:

I've subscribed to the issue. if I understood properly the issue will not be fixed until 20.10 is in for release ? (from quote : "the plan is to fix this when v20.10.0 goes in for docker")

1 Like

there is also this note from @aparcar

best place to find him is #openwrt-devel @ freenode

Yes this is what I noticed, but some stuff does not work:

  • if I install uxc, podman still ask to have runc which I think uxc is replacing
  • if I get runc then I can spawn containers but it seems the tty option of podman run is not working.

I don't know how much other things is still in the work for podman, so it's probably to be expected

One thing I'm a bit concerned about if podman replace docker for openwrt is the available orchestrations tools that we'll be able to use. A lot of people rely on docker-compose.

Alternatives for podman orchestration exists but:

  • pod configs for podman is using a different paradigm, surely not a show stopper but it might be a bit daunting for new comers used to compose
  • podman-compose is still a work in progress tool

in any case podman having most of its interface similar to docker is reassuring for me. Looking at the doc and unavailability if felt like people would have to rely streight into uxc and docker was removed from the plans for 20.10

Anyway thanks a lot for all answers, very much appreciated ! :slight_smile:

1 Like

What does that have to do with Docker on OpenWRT?

To @replicajune - right now, if you want to play with Docker you'll need to self-build and comment out a line in the Makefile for docker-ce to disable that runc version check, or put the patches from the pull request in your local build.

it's fixed :slight_smile:

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

the package setup was updated and since the package can be built now, it's not missing in the repos anymore

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.