Do you restart your router / how often?

A SIGHUP should do the trick...

"Should" or "does"? This is a rather moot discussion....

Indeed. Does. This is not distro specific.

But lets leave it at that :wink:

I want to reiterate what @eduperez said:

OpenWrt developers work really hard to design a system that could run perpetually. There are NO circumstances that should require a reboot to 'clear stuff out' in normal operation.

If you reliably encounter a problem that occurs after running for a while, please help us out and report it as a bug Thanks.


after almost 8 months of uptime, i HAD to do a power cycle.
it's my old trusty WR1043N and i noticed an unknown device with no MAC connected to wifi that i couldn't identify being mine. other than that it was working with no issues.
i did a software reboot and - it never came up again. switch ports working, passing traffic normally, but router part was dead, no ping, no internet access, but wifi active.
being located in a remote apartment that has guests now, i had to drive till there, enter the house, enter the locked storage room and unplug the router.
1st time ever that openwrt didn't boot successfully after a soft reboot.

I agree. But can you point me to where I can find proper troubleshooting techniques? I know I have a problem but have not been able to troubleshoot it as my networking / Linux capabilities are novice at best. I continue to look in this forum but not been able to find troubleshooting techniques or specific set up criteria for my situation.

You have to have the knowledge of what is correct and what isn't correct. Unfortunately, I do not possess this talent... I can run a recipe - thats about it....

Any pointers in the right direction would be greatly appreciated....


Create a new thread with a description of the problem and your config files. We’ll help you troubleshoot from there.


I had to hard power mine off and on yesterday. There were intermittent issues loading pages and nothing was showing in the system log (the issue lasted a few days). I tried a software Restart and still no lock. As soon as I did a hard power off and back on, it was good.