Dnsmasq listening port

Why is my dns not redirect to local listening port 5353?
Thanks

dhcp

config dnsmasq 'main'
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        list interface 'wifi0'
        option port '5353'

Additional firewall

config redirect
        option name 'Divert LAN DNS'
        option src 'lan'
        option proto 'tcp udp'
        option src_dport '53'
        option dest_port '5353'
        option target 'DNAT'

What are you trying to accomplish?

If redirecting local clients to DNS on your OpenWRT box, it might be easier and more maintainable to keep your DNS on port 53 and annouce that in the DHCP you send them.

Hi!
Check your interface option in dnsmasq.
I dont think wifi0 is right here x)

option proto in firewall config should be tcpudp without space.

Problem solved

Thanks