Dnsmasq dhcp-script not working after upgrade from release 21 to 22


my dhcp-script in the dnsmasq section is broken, I found another thread but without any solution. any ideas how to solve that? :frowning:

thx in advance!

so long

1 Like

Did you try to keep your old settings from 21.x?

There are many changes made from one release to another and these changes include cli syntax, so if you kept your old settings, the new release wonโ€™t understand it.

If this is the case, youโ€™ll need to factory reset and setup your configs manually using the correct syntax or via luci which is easier and more user friendly.

You probably need to use hotplug:

1 Like

thx, yes I tried to keep the settings but the script won't get executed.
I also tried to put that script into /etc/hotplug.d/dhcp but without success. DNSMASQ even fails to start when the script is in that directory, ofc I edited the dnsmasq.conf file and set the correct path.

thx! so long

edit: its that script: https://gist.github.com/jwalanta/53f55d03fcf5265938b64ffd361502d5

Remove the option dhcp-script since Hotplug does not need it.
If the issue persists, check the system log for dnsmasq errors.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.