Dnsmasq configuration

Hi everyone

I have been through the documentation and tried to configure dnsmasq as I want, but it isn't working quite right.

My router receives a public ip, and dns setting from my isp.

Here is what I want to do:

I want the router to disregard the dns from my isp, and use google (or or openDNS) instead.

I think my problem is I get the server and nameserver configuration-options in dnsmasq mixed, but perhaps I have a more fundamental lacking knowledge about how dhcp and dns actually works.

Thanks in advance

Configure this on the advanced settings page of the WAN interface (under custom DNS servers), not in the dnsmasq settings. Should get you what you're going for.


Thank you so much!

that was excatly what I was looking for!

If your problem is solved, please consider marking the topic as [Solved] (Click the pencil behind the topic...).

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.