DNSmasq and Alias interface


I am trying to run a DNS service (not dnsmasq) on a separate ip. I created an alias on the lan interface as shown below.
BUT: dnsmasq (which is running for the lan interface) also binds to this alias interface...
Is this the wrong approach or .....
I already have option nonwildcard '1' configured...

config interface 'lan2'
        option ifname '@lan'
        option proto 'static'
        option netmask ''
        option delegate '0'
        option ipaddr ''

Or better use a custom port and a firewall redirect.
Otherwise you may need to deal with race conditions.

Well, i tried the notinterface option, that didnt work strangely enough......

At the moment i have listen-address in dnsmasq.conf, which seems to work...

I am trying to do very similar configuration (two dnsmasqs) and so far I was able only to do it by using second physical interface.
I think that notinterface option value have to be physical interface. For me it did not work with lan2, but it worked when I put eth2.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.