DNS TLS won't work

Hello there,

I installed unbound and then i did disable the dns on dnsmasq but still no luck.

This is what i did:

Install packages

opkg update
opkg install unbound-daemon
 
# Enable DNS encryption
uci set unbound.fwd_google.enabled="1"
uci set unbound.fwd_google.fallback="0"
uci commit unbound
/etc/init.d/unbound restart

And disabled dns role so:

/etc/init.d/dnsmasq stop
uci set dhcp.@dnsmasq[0].localuse="0"
uci set dhcp.@dnsmasq[0].port="0"
uci commit dhcp
/etc/init.d/dnsmasq start

What else could be wrong?

What's the expected outcome?

That i do see TLS enabled when i run check-in like cloudflare help page.

I followed this guide to get unbound working with dnsmasq. I am using the basic serial method. You might want to revert your settings and start over installing all of the unbound packages for luci and the control package for logging and statistics. What made it work reliably for me was using a resolver like Cloudflare or Google and making sure my config files redirected DNS traffic properly.

1 Like

Seems the DoH proxy package's a lot easier to setup....

1 Like

That one is i just tested it 2 min ago and that one works nice.

Unbound for some reason really dont want to work here i kinda gave up as DOH works.

Appreciated but it really isnt working for me and i cant find out why, as DOH works i gave up on TLS.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.