DNS Resolving not working

Sorry if this question has been asked a million times and I didn't read the documentation properly.

A few weeks ago I found out about OpenWRT. Decided to pick up the firmware for my TP-LINK TL-WR941ND. It worked the first day, but after that it never did again.

Problem being that for some reason the DNS resolver doesn't work properly. I can ping IP addresses successfully, and even connect to the internet with Tor, but visiting standard web addresses doesn't work at all.

I tried ping, traceroute and nslookup, and all of them failed. My main router's (which provides my OpenWRT router with internet) IP address is, could this be the problem?

@someonethatsnoone, welcome to the community!

Yes, this is most likely your problem. Two networks on either side of a routing plane cannot be identically numbered. One of your networks has to be changed from to something else (e.g. This is a basic networking concept, so it likely isn't found in any OpenWrt-specific documentation. The reasoning is: the router thinks it's the same network mathematically, so it has nothing to route from LAN to WAN. Hope this helps.