DNS problem ? configuration stopped working I dont know why

Hello, i did some upgrades and now my configuration stopped working, I'm unable to go back or forward:
A - Internet provider router (wifi turned off) @ip 192.168.1.254
B - GL.iNet GL-B1300 @ip 192.168.2.1 wan port is connected via cable to the provider's router lan port
C - Netgear Extender EX6150v2 @ip 192.168.2.10 connected via cable to the GL-B1300

This configuration WORKED for months now, but yesterday while I was messing with v21-rc1 stopped and i'm unable to make it work anymore. I think it can be a DNS related issue but also configuring CiscoDNS in lan or WAN doesnt solve the issues. I cant navigate...

my "NETWORK" file:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd1f:cfe5:960a::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.254'

config interface 'wan'
	option ifname 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.2'
	option gateway '192.168.1.254'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '3 4 0'

my "DHCP" file:

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

Thanks in advance for any help

Please anyone...

cat /tmp/resolv.conf.auto

which DNSes does the clients get assigned via DHCP ?

If you have a static IP on the WAN port of the GL.inet, you manually have to provide DNSes for the DHCP leases, as in https://openwrt.org/docs/guide-user/base-system/dhcp_configuration , option 6.

Hi and thanks, here is the file content.

/tmp/resolv.conf.auto

# Interface wan6
nameserver fe80::1%eth1

Btw what does it mean "you manually have to provide DNSes for the DHCP leases"
I should enter this with the desired DNS?

uci add_list dhcp.lan.dhcp_option="3,192.168.1.2"
uci add_list dhcp.lan.dhcp_option="6,172.16.60.64"
uci add_list dhcp.lan.dhcp_option="42,172.16.60.64"
uci add_list dhcp.lan.dhcp_option="44"
uci commit dhcp
/etc/init.d/dnsmasq restart

Thankyou for helping

correct
https://www.iana.org/assignments/bootp-dhcp-parameters/bootp-dhcp-parameters.xhtml

If I set the LAN to DHCP I can skip this? I'm trying to have a simple config

No, you need to set the GL.inet WAN to DHCP, then it'll inherit whatever's provided by your ISP,
but that's not really what you want.

if you want to have custom DNSes, the DHCP config is necessary either in the ISPs DHCP, or your own.

or intercept all DNS calls in the FW, and redirect them to whatever IP you'd like them to go to.

Ok I understood the concept thank a lot. Not sure I understood the setup example btw, I put comments inside:

uci add_list dhcp.lan.dhcp_option="3,192.168.1.2"   <---- I should use my modem IP? 192.168.1.254??
uci add_list dhcp.lan.dhcp_option="6,172.16.60.64" <---- I can put 208.67.222.123
uci add_list dhcp.lan.dhcp_option="42,172.16.60.64" <--- I can put 208.67.222.123
uci add_list dhcp.lan.dhcp_option="44" <--- leave like that
uci commit dhcp
/etc/init.d/dnsmasq restart

probably only need uci add_list dhcp.lan.dhcp_option="6,208.67.222.123" but if that's not good enough, add the uci add_list dhcp.lan.dhcp_option="3,192.168.2.1"

Thankyou very much I will try in some hour and let you know
Again thankyou

Well, I've reinstalled everything from scratch, with exactly the same config shown before, and now 21.02-rc1 seems to be working.
Btw also if it was working with previous config now, I've added:

uci add_list dhcp.lan.dhcp_option="6,208.67.222.123,208.67.220.123" 
uci add_list dhcp.lan.dhcp_option="3,192.168.2.1"
uci commit dhcp
/etc/init.d/dnsmasq restart

and it keeps working well, now I have 18hours uptime and 4 pcs working well.
Btw thanks again for help
Regards