DNS problem after switching to Sky from VM

Hello friends!

I am in the UK and moved from Virgin Media (VM) to Sky. VM had a cable modem broadband connection and it worked well with my BTHH5A running OpenWRT 19.07. Sky is a VDSL2 connection. I followed the steps mentioned on page 45 in the ebilan guide : https://www.dropbox.com/sh/c8cqmpc6cacs5n8/AAA2f8htk1uMitBckDW8Jq88a?dl=0

I can connect to isp over DSL. The wan interface gets a public ip address. However, I can't ping to any host such as 'ping bbc.co.uk'. I have to provide ip address for pinging. Also I can't browse over http or https.

nslookup myip.opendns.com resolver1.opendns.com on LAN client laptop gives 'query refused' error. But nslookup myip.opendns.com shows my public ip.

It seems my dns are not set properly.

Here are the DSL Line parameters :

DSL Status
Line State                             : UP [0x0]
Line Mode                              : G.993.2 (VDSL2)
Line Uptime                            : 8m 59s
Annex                                  : B
Profile                                : 17a
Data Rate                              : 25.689 Mb/s / 4.532 Mb/s
Max. Attainable Data Rate (ATTNDR)     : 29.719 Mb/s / 4.553 Mb/s
Latency                                : 8.0 ms / 0.0 ms
Line Attenuation (LATN)                : 29.3 dB / 40.0 dB
Signal Attenuation (SATN)              : 26.9 dB / 27.7 dB
Noise Margin (SNR)                     : 6.1 dB / 6.1 dB
Aggregate Transmit Power (ACTATP)      : 4.4 dB / 4.4 dB
Forward Error Correction Seconds (FECS): 0 / 0
Errored seconds (ES)                   : 0 / 8
Severely Errored Seconds (SES)         : 0 / 0
Loss of Signal Seconds (LOSS)          : 0 / 56
Unavailable Seconds (UAS)              : 54 / 54
Header Error Code Errors (HEC)         : 0 / 0
Non Pre-emptive CRC errors (CRC_P)     : 0 / 0
Pre-emptive CRC errors (CRCP_P)        : 0 / 0
ATU-C System Vendor ID                 : Infineon 178.6
Power Management Mode                  : L0 - Synchronized

Here are my network details pertaining to dsl :

~# uci show network.dsl

~# uci show network.wan

~# uci show network.wan_dsl0_dev

I've set in 3 places in LuCI :

  1. Network --> Interface --> WAN --> (edit) --> Advanced Settings --> Use custom DNS servers -->
    Option 'Use DNS servers advertised by peer' is unticked.

  2. Network --> Interface --> LAN --> (edit) --> General Settings --> Use custom DNS servers -->

  3. Network --> Interface --> LAN --> (edit) --> Advanced Settings --> DHCP-Options --> 6,

Still no joy. How do I debug? Please let me know your views.

Thank you!


Check if DNS server in question is working for you, run
nslookup openwrt.org (or use any other public resolver IP there)
Once you found the working server(s), put the server IP(s) in only one place that is
Network --> DHCP and DNS --> DNS forwardings

Since it's DSL I had to check the VPI: 0 \ VCI: 38 to make sure that's configured on the DSL side for connectivity to get beyond the WAN into the Sky network and pass traffic. Being able to ping by IP means you have full connectivity though and just lack DNS responses from the ISP.

Might just be a typo but, should be

Can you provide:
ipconfig /all
tracert google.com

This should confirm some of the potential issue.

Hi @AndrewZ ,

Putting opendns servers IPs in just one place as you said, worked. Thank you. Don't know why Sky needs this setting. VM worked without. Sky is unpredictable at best and whimsical at worst.


Hi @Tech_Junky ,

I had empty DNS Forwardings. Put opendns servers IPs there and it worked. Thank you for your suggestions.


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.