DNS on clients, but none on router

Hello - just updated to 21.02 and I'm having DNS issues. I am running a pihole locally for DNS. Using OpenWrt's DHCP setting, I'm pushing the DNS server IP ( to clients and that seems to work. However, the router itself insists (in /etc/resolv.conf) on using as the DNS server, which fails.

I've tried (in Luci) going to Interfaces->LAN and adding the IP under "Use custom DNS servers", but that didn't resolve the issue. If I edit /etc/resolv.conf to point to, I get DNS resolution but of course it gets overwritten if I make any changes to DHCP etc.

I could use some help! I'd tried what seems obvious and what I found from a web search. Thanks in advance.

1 Like
1 Like

Seems to work - can you explain what it does? :slight_smile:

1 Like

Some config paths have changed in the latest release.
You need to update it manually as you kept the old settings.

Would it be easier (and more compatible with any future upgrades) if I just did a sysupgrade without asking it to save the settings? (can I do that by doing "Perform reset" in LuCI without flashing again?"

1 Like

Yep, that should work, see also:
Preserving OpenWrt settings during firmware upgrade

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.