DNS leaking on wireguard (Mullvad)


#1

This is the second time i have gone thru this. Whatever worked on my other router did not work here.

I followed the Mullvad wireguard instructions and placed the mullvad dns in the firewall as instructed and the proper DHCP-options in lan.

That didnt work at all. It showed my wireguard IP and leaked the dns. i placed the ipaddress for mullvads DNS in the netmask ipv4 section at now it gives me google dns in taiwan (Im in EU). I went to check on dnsleaktest.com and did an extended test and still get the taiwan address for google only.

Is this safe or an issue I need to fix? The server is for japan wireguard. When I did the other router it showed up no leaks when i checked via mullvad.


#2
  • Have you made routes for the IPs of the DNS servers you configured - to use your Wireguard interface?
  • Did you add your DNS servers to the System, LAN or WAN section?

#3

Yes I did exactly like the instructions. When i do that instructions say it still shows my local internet service.

In lan i set the dhcp options there. If I leave out the ipv4 netmask it shows local provider. If i add in the IPv4 netmask it gives google taiwan. Thats using the 193.138.219.228 ip address.


#4

Interesting thing is my other desktop plugged in to the router directly shows the proper response to the DNS leak test. But the laptop when plugged in shows google taiwan


#5

Check your network settings on the laptop ( dns settings )


#6

Ok thanks. Now Im having another issue. On wireless using my mobile I can connect to internet. But not using the laptop on wireless. Shows internet but no connection.

I pull a second laptop and connects to wireless but says no internet.

Just rebooted it and freezes. For a time when i turn it back on it shows network openwrt then goes to unidentified network and I cant access at all....